summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorShashank Ram <rams@vmware.com>2018-01-31 18:58:56 -0800
committerAlin Gabriel Serdean <aserdean@ovn.org>2018-02-06 18:14:02 +0200
commit845e688435a38670f1364e322a39d0ff3bd87604 (patch)
treed4620fb50094e181270a187b243ce0655dd5d7b4 /Makefile.am
parentdb5c4c74506ae91a4bafbe129378f6117e694fca (diff)
downloadopenvswitch-845e688435a38670f1364e322a39d0ff3bd87604.tar.gz
datapath-windows: Specify platform arch during compilation
Newer compilers expect the platorm architecture to be passed. Signed-off-by: Shashank Ram <rams@vmware.com> Acked-by: Alin Gabriel Serdean <aserdean@ovn.org> Signed-off-by: Alin Gabriel Serdean <aserdean@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 8632d6993..d397f652f 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -409,14 +409,15 @@ CLEANFILES += manpage-dep-check
if VSTUDIO_DDK
ALL_LOCAL += ovsext
+ARCH = x64
ovsext: datapath-windows/ovsext.sln $(srcdir)/datapath-windows/include/OvsDpInterface.h
- MSBuild.exe //nologo //maxcpucount datapath-windows/ovsext.sln /target:Build /property:Configuration="Win8$(VSTUDIO_CONFIG)" /property:Version="$(PACKAGE_VERSION)"
- MSBuild.exe //nologo //maxcpucount datapath-windows/ovsext.sln /target:Build /property:Configuration="Win8.1$(VSTUDIO_CONFIG)" /property:Version="$(PACKAGE_VERSION)"
+ MSBuild.exe //nologo //maxcpucount datapath-windows/ovsext.sln /target:Build /property:Configuration="Win8$(VSTUDIO_CONFIG)" /property:Version="$(PACKAGE_VERSION)" //p:Platform=$(ARCH)
+ MSBuild.exe //nologo //maxcpucount datapath-windows/ovsext.sln /target:Build /property:Configuration="Win8.1$(VSTUDIO_CONFIG)" /property:Version="$(PACKAGE_VERSION)" //p:Platform=$(ARCH)
CLEAN_LOCAL += ovsext_clean
ovsext_clean: datapath-windows/ovsext.sln
- MSBuild.exe //nologo //maxcpucount datapath-windows/ovsext.sln /target:Clean /property:Configuration="Win8$(VSTUDIO_CONFIG)" /property:Version="$(PACKAGE_VERSION)"
- MSBuild.exe //nologo //maxcpucount datapath-windows/ovsext.sln /target:Clean /property:Configuration="Win8.1$(VSTUDIO_CONFIG)" /property:Version="$(PACKAGE_VERSION)"
+ MSBuild.exe //nologo //maxcpucount datapath-windows/ovsext.sln /target:Clean /property:Configuration="Win8$(VSTUDIO_CONFIG)" /property:Version="$(PACKAGE_VERSION)" //p:Platform=$(ARCH)
+ MSBuild.exe //nologo //maxcpucount datapath-windows/ovsext.sln /target:Clean /property:Configuration="Win8.1$(VSTUDIO_CONFIG)" /property:Version="$(PACKAGE_VERSION)" //p:Platform=$(ARCH)
endif
.PHONY: ovsext