summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAaron Conole <aconole@redhat.com>2017-08-31 19:22:44 -0400
committerAnsis Atteka <aatteka@ovn.org>2017-08-31 16:27:42 -0700
commit8e6681eaa612c70c2afdb4b5a68c18e9cd3940a8 (patch)
treea2d8af3f424175a3d27293561d9d3de425b6a665 /Makefile.am
parent7bc1aae71e8908d775d988f82f683533f253e6f4 (diff)
downloadopenvswitch-8e6681eaa612c70c2afdb4b5a68c18e9cd3940a8.tar.gz
makefile: hook up dpdkstrip preprocessor
When building the openvswitch-custom.te file, it is important to have the ability to filter out dpdk blocks depending on whether the system has been configured with dpdk or not. This allows using all the standard .in file blocks, as well as the dpdkstrip blocks, when constructing the selinux policy file. Additionally, this means any .in files which might want to change based on configuration to exclude blocks based on dpdk can do so. Acked-by: Flavio Leitner <fbl@sysclose.org> Acked-by: Ansis Atteka <aatteka@ovn.org> Signed-off-by: Aaron Conole <aconole@redhat.com> Tested-by: Jean Hsiao <jhsiao@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 035afe60b..31d633179 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -35,6 +35,9 @@ AM_CFLAGS += $(OVS_CFLAGS)
if DPDK_NETDEV
AM_CFLAGS += -D_FILE_OFFSET_BITS=64
+DPDKSTRIP_FLAGS = --dpdk
+else
+DPDKSTRIP_FLAGS = --nodpdk
endif
if NDEBUG
@@ -141,6 +144,7 @@ ro_shell = printf '\043 Generated automatically -- do not modify! -*- buffer-
SUFFIXES += .in
.in:
$(AM_V_GEN)$(PERL) $(srcdir)/build-aux/soexpand.pl -I$(srcdir) < $< | \
+ $(PERL) $(srcdir)/build-aux/dpdkstrip.pl $(DPDKSTRIP_FLAGS) | \
sed \
-e 's,[@]PKIDIR[@],$(PKIDIR),g' \
-e 's,[@]LOGDIR[@],$(LOGDIR),g' \