summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRussell Bryant <russell@ovn.org>2015-12-14 10:21:53 -0500
committerRussell Bryant <russell@ovn.org>2016-01-12 11:47:33 -0500
commit8ea171aba044bf605c31313330ccabfc4fc5846c (patch)
treee70eb368b777364217575964b96d220da07c951c /Makefile.am
parentf3068bff92dc4fb76ee4aab149990f2492bcbc24 (diff)
downloadopenvswitch-8ea171aba044bf605c31313330ccabfc4fc5846c.tar.gz
python: Fix print function compatibility.
The print statement from Python 2 is a function in Python 3. Enable print function support for Python 2 and convert print statements to function calls. Enable the H233 flake8 warning. If the hacking plugin is installed, this will generate warnings for print statement usage not compatible with Python 3. H233 Python 3.x incompatible use of print operator Signed-off-by: Russell Bryant <russell@ovn.org> Acked-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 615d45694..9be2b96c2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -360,8 +360,9 @@ ALL_LOCAL += flake8-check
# D*** -- warnings from flake8-docstrings plugin
# H*** -- warnings from flake8 hacking plugin (custom style checks beyond PEP8)
# H231 Python 3.x incompatible 'except x,y:' construct
+# H233 Python 3.x incompatible use of print operator
flake8-check: $(FLAKE8_PYFILES)
- $(AM_V_GEN) if flake8 $^ --select=H231 --ignore=E121,E123,E125,E126,E127,E128,E129,E131,W503,F811,D,H ${FLAKE8_FLAGS}; then touch $@; else exit 1; fi
+ $(AM_V_GEN) if flake8 $^ --select=H231,H233 --ignore=E121,E123,E125,E126,E127,E128,E129,E131,W503,F811,D,H ${FLAKE8_FLAGS}; then touch $@; else exit 1; fi
endif
include $(srcdir)/manpages.mk