summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorRussell Bryant <russell@ovn.org>2017-03-07 11:14:30 -0500
committerRussell Bryant <russell@ovn.org>2017-03-07 14:47:31 -0500
commit92d8490fa2d954219d0307835d6df6c3efb7b221 (patch)
tree93e2ea920d41f2ae408ba804c2b4042f7dc56357 /Makefile.am
parent0d11fc526bb54745c2be6fe7e227c30cd6272deb (diff)
downloadopenvswitch-92d8490fa2d954219d0307835d6df6c3efb7b221.tar.gz
flake8: Fix build with flake8-import-order installed.
OpenStack CI is currently failing due to some flake8 warnings emitted from the flake8-import-order plugin. Just ignore all of those warnings since they're just style things that aren't important. Signed-off-by: Russell Bryant <russell@ovn.org> Acked-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index a4dd7b8dd..cdf42d3ad 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -350,7 +350,7 @@ ALL_LOCAL += flake8-check
# H233 Python 3.x incompatible use of print operator
# H238 old style class declaration, use new style (inherit from `object`)
FLAKE8_SELECT = H231,H232,H233,H238
-FLAKE8_IGNORE = E121,E123,E125,E126,E127,E128,E129,E131,W503,F811,D,H
+FLAKE8_IGNORE = E121,E123,E125,E126,E127,E128,E129,E131,W503,F811,D,H,I
flake8-check: $(FLAKE8_PYFILES)
$(AM_V_GEN) \
src='$^' && \