summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2017-03-07 16:29:53 -0800
committerBen Pfaff <blp@ovn.org>2017-03-07 16:43:09 -0800
commit939f4522e5f539f3aeb3a64434ef6cdf28a0dafa (patch)
tree1e143bbfe865711021ef6cdcff5b2093131e773e /Makefile.am
parent4ae3db4a792395bf83baba9bff352011e46a583b (diff)
downloadopenvswitch-939f4522e5f539f3aeb3a64434ef6cdf28a0dafa.tar.gz
Makefile: Break the build if .gitignore files are distributed.
This would have found a .gitignore file recently added to the distribution. CC: Alin Gabriel Serdean <aserdean@cloudbasesolutions.com> Signed-off-by: Ben Pfaff <blp@ovn.org> Reviewed-by: Markos Chandras <mchandras@suse.de>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index cdf42d3ad..90f5c0353 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,4 +1,4 @@
-# Copyright (C) 2007-2016 Nicira, Inc.
+# Copyright (C) 2007-2017 Nicira, Inc.
#
# Copying and distribution of this file, with or without modification,
# are permitted in any medium without royalty provided the copyright
@@ -203,6 +203,11 @@ dist-hook-git: distfiles
cat missing-distfiles; \
exit 1; \
fi; \
+ if LC_ALL=C grep '\.gitignore$$' all-distfiles; then \
+ echo "See above for list of files that are distributed but"; \
+ echo "should not be."; \
+ exit 1; \
+ fi \
fi
CLEANFILES += all-distfiles all-gitfiles missing-distfiles
# The following is based on commands for the Automake "distdir" target.