summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorFlavio Leitner <fbl@sysclose.org>2020-06-10 16:49:45 -0300
committerWilliam Tu <u9012063@gmail.com>2020-07-04 15:42:38 -0700
commit9ed9df77a3097146addd9cc2f53bffebd71c1343 (patch)
tree6509026e33b4b311b8ad7c6fa67ed72c3d26a3ca /Makefile.am
parent0fc38297ba3830631e4a6ad3f9fbbe364e8a3b6b (diff)
downloadopenvswitch-9ed9df77a3097146addd9cc2f53bffebd71c1343.tar.gz
ctags: Include new annotations to ctags ignore list.
The annotation OVS_NO_THREAD_SAFETY_ANALYSIS and OVS_LOCKABLE are not part of the list, so ctags can't find functions using them. The annotation list comes from a regex and to include more items make the regex more difficult to read and maintain. Convert to a static list because it isn't supposed to change much and there is no standard names. Also add a comment to remind to keep the list up-to-date. Signed-off-by: Flavio Leitner <fbl@sysclose.org> Signed-off-by: William Tu <u9012063@gmail.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index b279303d1..27ef9e4b4 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -46,7 +46,7 @@ AM_CPPFLAGS += -DNDEBUG
AM_CFLAGS += -fomit-frame-pointer
endif
-AM_CTAGSFLAGS = $(OVS_CTAGS_IDENTIFIERS_LIST)
+AM_CTAGSFLAGS = -I "$(OVS_CTAGS_IDENTIFIERS_LIST)"
if WIN32
psep=";"