summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorStephen Finucane <stephen@that.guru>2017-01-02 11:47:42 +0000
committerBen Pfaff <blp@ovn.org>2017-01-04 08:56:20 -0800
commitaca1bb54c566db1d6bd1a9dc05a5f2197a356fbb (patch)
treef9fd1cc19bab0db1c71fcbda5f4491e0126c2887 /Makefile.am
parentd84bdc8236801e95e976b65de09ac90b92e37998 (diff)
downloadopenvswitch-aca1bb54c566db1d6bd1a9dc05a5f2197a356fbb.tar.gz
make: Standardize indentation
If we're going to mix tabs and spaces, let's do it consistently. Signed-off-by: Stephen Finucane <stephen@that.guru> [blp@ovn.org reformatted the flake8-check commands] Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am184
1 files changed, 94 insertions, 90 deletions
diff --git a/Makefile.am b/Makefile.am
index 74839e148..0808550ed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,44 +137,44 @@ ro_shell = printf '\043 Generated automatically -- do not modify! -*- buffer-
SUFFIXES += .in
.in:
$(AM_V_GEN)$(PERL) $(srcdir)/build-aux/soexpand.pl -I$(srcdir) < $< | \
- sed \
- -e 's,[@]PKIDIR[@],$(PKIDIR),g' \
- -e 's,[@]LOGDIR[@],$(LOGDIR),g' \
- -e 's,[@]DBDIR[@],$(DBDIR),g' \
- -e 's,[@]PERL[@],$(PERL),g' \
- -e 's,[@]PYTHON[@],$(PYTHON),g' \
- -e 's,[@]RUNDIR[@],$(RUNDIR),g' \
- -e 's,[@]VERSION[@],$(VERSION),g' \
- -e 's,[@]localstatedir[@],$(localstatedir),g' \
- -e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
- -e 's,[@]sysconfdir[@],$(sysconfdir),g' \
- -e 's,[@]bindir[@],$(bindir),g' \
- -e 's,[@]sbindir[@],$(sbindir),g' \
- -e 's,[@]abs_builddir[@],$(abs_builddir),g' \
- -e 's,[@]abs_top_srcdir[@],$(abs_top_srcdir),g' \
- > $@.tmp
+ sed \
+ -e 's,[@]PKIDIR[@],$(PKIDIR),g' \
+ -e 's,[@]LOGDIR[@],$(LOGDIR),g' \
+ -e 's,[@]DBDIR[@],$(DBDIR),g' \
+ -e 's,[@]PERL[@],$(PERL),g' \
+ -e 's,[@]PYTHON[@],$(PYTHON),g' \
+ -e 's,[@]RUNDIR[@],$(RUNDIR),g' \
+ -e 's,[@]VERSION[@],$(VERSION),g' \
+ -e 's,[@]localstatedir[@],$(localstatedir),g' \
+ -e 's,[@]pkgdatadir[@],$(pkgdatadir),g' \
+ -e 's,[@]sysconfdir[@],$(sysconfdir),g' \
+ -e 's,[@]bindir[@],$(bindir),g' \
+ -e 's,[@]sbindir[@],$(sbindir),g' \
+ -e 's,[@]abs_builddir[@],$(abs_builddir),g' \
+ -e 's,[@]abs_top_srcdir[@],$(abs_top_srcdir),g' \
+ > $@.tmp
@if head -n 1 $@.tmp | grep '#!' > /dev/null; then \
- chmod +x $@.tmp; \
+ chmod +x $@.tmp; \
fi
$(AM_V_at) mv $@.tmp $@
SUFFIXES += .xml
%: %.xml
$(AM_V_GEN)$(run_python) $(srcdir)/build-aux/xml2nroff $< > $@.tmp \
- -I $(srcdir) \
- --version=$(VERSION) \
- PKIDIR='$(PKIDIR)' \
- LOGDIR='$(LOGDIR)' \
- DBDIR='$(DBDIR)' \
- PERL='$(PERL)' \
- PYTHON='$(PYTHON)' \
- RUNDIR='$(RUNDIR)' \
- VERSION='$(VERSION)' \
- localstatedir='$(localstatedir)' \
- pkgdatadir='$(pkgdatadir)' \
- sysconfdir='$(sysconfdir)' \
- bindir='$(bindir)' \
- sbindir='$(sbindir)'
+ -I $(srcdir) \
+ --version=$(VERSION) \
+ PKIDIR='$(PKIDIR)' \
+ LOGDIR='$(LOGDIR)' \
+ DBDIR='$(DBDIR)' \
+ PERL='$(PERL)' \
+ PYTHON='$(PYTHON)' \
+ RUNDIR='$(RUNDIR)' \
+ VERSION='$(VERSION)' \
+ localstatedir='$(localstatedir)' \
+ pkgdatadir='$(pkgdatadir)' \
+ sysconfdir='$(sysconfdir)' \
+ bindir='$(bindir)' \
+ sbindir='$(sbindir)'
$(AM_v_at)mv $@.tmp $@
clean-pycov:
@@ -192,17 +192,17 @@ if GNU_MAKE
ALL_LOCAL += dist-hook-git
dist-hook-git: distfiles
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1; then \
- (cd datapath && $(MAKE) distfiles); \
- (cat distfiles; sed 's|^|datapath/|' datapath/distfiles) | \
- LC_ALL=C sort -u > all-distfiles; \
- (cd $(srcdir) && git ls-files) | grep -v '\.gitignore$$' | \
- LC_ALL=C sort -u > all-gitfiles; \
+ (cd datapath && $(MAKE) distfiles); \
+ (cat distfiles; sed 's|^|datapath/|' datapath/distfiles) | \
+ LC_ALL=C sort -u > all-distfiles; \
+ (cd $(srcdir) && git ls-files) | grep -v '\.gitignore$$' | \
+ LC_ALL=C sort -u > all-gitfiles; \
LC_ALL=C comm -1 -3 all-distfiles all-gitfiles > missing-distfiles; \
- if test -s missing-distfiles; then \
+ if test -s missing-distfiles; then \
echo "The following files are in git but not the distribution:"; \
- cat missing-distfiles; \
- exit 1; \
- fi; \
+ cat missing-distfiles; \
+ exit 1; \
+ fi; \
fi
CLEANFILES += all-distfiles all-gitfiles missing-distfiles
# The following is based on commands for the Automake "distdir" target.
@@ -213,7 +213,7 @@ distfiles: Makefile
for file in $$list; do echo $$file; done | \
sed -e "s|^$$srcdirstrip/||;t" \
-e "s|^$$topsrcdirstrip/|$(top_builddir)/|;t" | \
- LC_ALL=C sort -u > $@
+ LC_ALL=C sort -u > $@
CLEANFILES += distfiles
endif
.PHONY: dist-hook-git
@@ -223,12 +223,12 @@ ALL_LOCAL += config-h-check
config-h-check:
@cd $(srcdir); \
if test -e .git && (git --version) >/dev/null 2>&1 && \
- git --no-pager grep -L '#include <config\.h>' `git ls-files | grep '\.c$$' | \
- grep -vE '^datapath|^lib/sflow|^third-party|^datapath-windows|^python'`; \
+ git --no-pager grep -L '#include <config\.h>' `git ls-files | grep '\.c$$' | \
+ grep -vE '^datapath|^lib/sflow|^third-party|^datapath-windows|^python'`; \
then \
- echo "See above for list of violations of the rule that"; \
- echo "every C source file must #include <config.h>."; \
- exit 1; \
+ echo "See above for list of violations of the rule that"; \
+ echo "every C source file must #include <config.h>."; \
+ exit 1; \
fi
.PHONY: config-h-check
@@ -237,13 +237,13 @@ ALL_LOCAL += printf-check
printf-check:
@cd $(srcdir); \
if test -e .git && (git --version) >/dev/null 2>&1 && \
- git --no-pager grep -n -E -e '%[-+ #0-9.*]*([ztj]|hh)' --and --not -e 'ovs_scan' `git ls-files | grep '\.[ch]$$' | \
- grep -vE '^datapath|^lib/sflow|^third-party'`; \
+ git --no-pager grep -n -E -e '%[-+ #0-9.*]*([ztj]|hh)' --and --not -e 'ovs_scan' `git ls-files | grep '\.[ch]$$' | \
+ grep -vE '^datapath|^lib/sflow|^third-party'`; \
then \
- echo "See above for list of violations of the rule that"; \
- echo "'z', 't', 'j', 'hh' printf() type modifiers are"; \
- echo "forbidden. See CodingStyle.rst for replacements."; \
- exit 1; \
+ echo "See above for list of violations of the rule that"; \
+ echo "'z', 't', 'j', 'hh' printf() type modifiers are"; \
+ echo "forbidden. See CodingStyle.rst for replacements."; \
+ exit 1; \
fi
.PHONY: printf-check
@@ -251,25 +251,25 @@ printf-check:
ALL_LOCAL += static-check
static-check:
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1 && \
- git --no-pager grep -n -E '^[ ]+(struct vlog_rate_limit|pthread_once_t|struct ovsthread_once).*=' $(srcdir); \
- then \
- echo "See above for list of violations of the rule that "; \
- echo "certain data structures must always be 'static'"; \
- exit 1; \
- fi
+ git --no-pager grep -n -E '^[ ]+(struct vlog_rate_limit|pthread_once_t|struct ovsthread_once).*=' $(srcdir); \
+ then \
+ echo "See above for list of violations of the rule that "; \
+ echo "certain data structures must always be 'static'"; \
+ exit 1; \
+ fi
.PHONY: static-check
# Check that assert.h is not used outside a whitelist of files.
ALL_LOCAL += check-assert-h-usage
check-assert-h-usage:
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1 && \
- (cd $(srcdir) && git --no-pager grep -l -E '[<]assert.h[>]') | \
- $(EGREP) -v '^lib/(sflow_receiver|vlog).c$$|^tests/'; \
- then \
- echo "Files listed above unexpectedly #include <""assert.h"">."; \
- echo "Please use ovs_assert (from util.h) instead of assert."; \
- exit 1; \
- fi
+ (cd $(srcdir) && git --no-pager grep -l -E '[<]assert.h[>]') | \
+ $(EGREP) -v '^lib/(sflow_receiver|vlog).c$$|^tests/'; \
+ then \
+ echo "Files listed above unexpectedly #include <""assert.h"">."; \
+ echo "Please use ovs_assert (from util.h) instead of assert."; \
+ exit 1; \
+ fi
.PHONY: check-assert-h-usage
# Check that LITTLE_ENDIAN and BIG_ENDIAN are not used unless BYTE_ORDER is
@@ -279,28 +279,28 @@ check-assert-h-usage:
ALL_LOCAL += check-endian
check-endian:
@if test -e $(srcdir)/.git && (git --version) >/dev/null 2>&1 && \
- (cd $(srcdir) && git --no-pager grep -l -E \
- -e 'BIG_ENDIAN|LITTLE_ENDIAN' --and --not -e 'BYTE_ORDER' | \
- $(EGREP) -v '^datapath/'); \
- then \
- echo "See above for list of files that misuse LITTLE""_ENDIAN"; \
- echo "or BIG""_ENDIAN. Please use WORDS_BIGENDIAN instead."; \
- exit 1; \
- fi
+ (cd $(srcdir) && git --no-pager grep -l -E \
+ -e 'BIG_ENDIAN|LITTLE_ENDIAN' --and --not -e 'BYTE_ORDER' | \
+ $(EGREP) -v '^datapath/'); \
+ then \
+ echo "See above for list of files that misuse LITTLE""_ENDIAN"; \
+ echo "or BIG""_ENDIAN. Please use WORDS_BIGENDIAN instead."; \
+ exit 1; \
+ fi
.PHONY: check-endian
ALL_LOCAL += thread-safety-check
thread-safety-check:
@cd $(srcdir); \
if test -e .git && (git --version) >/dev/null 2>&1 && \
- grep -n -f build-aux/thread-safety-blacklist \
- `git ls-files | grep '\.[ch]$$' \
- | $(EGREP) -v '^datapath|^lib/sflow|^third-party'` /dev/null \
- | $(EGREP) -v ':[ ]*/?\*'; \
+ grep -n -f build-aux/thread-safety-blacklist \
+ `git ls-files | grep '\.[ch]$$' \
+ | $(EGREP) -v '^datapath|^lib/sflow|^third-party'` /dev/null \
+ | $(EGREP) -v ':[ ]*/?\*'; \
then \
- echo "See above for list of calls to functions that are"; \
- echo "blacklisted due to thread safety issues"; \
- exit 1; \
+ echo "See above for list of calls to functions that are"; \
+ echo "blacklisted due to thread safety issues"; \
+ exit 1; \
fi
EXTRA_DIST += build-aux/thread-safety-blacklist
.PHONY: thread-safety-check
@@ -310,9 +310,9 @@ ALL_LOCAL += manpage-check
manpage-check: $(man_MANS) $(dist_man_MANS) $(noinst_man_MANS)
@error=false; \
for manpage in $?; do \
- LANG=en_US.UTF-8 groff -w mac -w delim -w escape -w input -w missing -w tab -T utf8 -man -p -z $$manpage >$@.tmp 2>&1; \
- if grep warning: $@.tmp; then error=:; fi; \
- rm -f $@.tmp; \
+ LANG=en_US.UTF-8 groff -w mac -w delim -w escape -w input -w missing -w tab -T utf8 -man -p -z $$manpage >$@.tmp 2>&1; \
+ if grep warning: $@.tmp; then error=:; fi; \
+ rm -f $@.tmp; \
done; \
if $$error; then exit 1; else touch $@; fi
$(AM_V_GEN) touch -c $@
@@ -342,10 +342,14 @@ ALL_LOCAL += flake8-check
# H232 Python 3.x incompatible octal 077 should be written as 0o77
# H233 Python 3.x incompatible use of print operator
# H238 old style class declaration, use new style (inherit from `object`)
+FLAKE8_SELECT = H231,H232,H233,H238
+FLAKE8_IGNORE = E121,E123,E125,E126,E127,E128,E129,E131,W503,F811,D,H
flake8-check: $(FLAKE8_PYFILES)
- $(AM_V_GEN) if flake8 $^ --select=H231,H232,H233,H238 ${FLAKE8_FLAGS} && \
- flake8 $^ --ignore=E121,E123,E125,E126,E127,E128,E129,E131,W503,F811,D,H ${FLAKE8_FLAGS}; then \
- touch $@; else exit 1; fi
+ $(AM_V_GEN) \
+ src='$^' && \
+ flake8 $$src --select=$(FLAKE8_SELECT) $(FLAKE8_FLAGS) && \
+ flake8 $$src --ignore=$(FLAKE8_IGNORE) $(FLAKE8_FLAGS) && \
+ touch $@
endif
CLEANFILES += flake8-check
@@ -353,10 +357,10 @@ include $(srcdir)/manpages.mk
$(srcdir)/manpages.mk: $(MAN_ROOTS) build-aux/sodepends.pl
@$(PERL) $(srcdir)/build-aux/sodepends.pl -I. -I$(srcdir) $(MAN_ROOTS) >$(@F).tmp
@if cmp -s $(@F).tmp $@; then \
- touch $@; \
- rm -f $(@F).tmp; \
+ touch $@; \
+ rm -f $(@F).tmp; \
else \
- mv $(@F).tmp $@; \
+ mv $(@F).tmp $@; \
fi
CLEANFILES += manpage-dep-check
@@ -375,7 +379,7 @@ endif
clang-analyze: clean
@which clang scan-build >/dev/null 2>&1 || \
- (echo "Unable to find clang/scan-build, Install clang,clang-analyzer packages"; exit 1)
+ (echo "Unable to find clang/scan-build, Install clang,clang-analyzer packages"; exit 1)
@$(MKDIR_P) "$(srcdir)/tests/clang-analyzer-results"
@scan-build -o $(srcdir)/tests/clang-analyzer-results --use-cc=$(CC) $(MAKE)
.PHONY: clang-analyze