summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAlin Gabriel Serdean <aserdean@ovn.org>2017-11-06 12:12:03 +0200
committerAlin Gabriel Serdean <aserdean@ovn.org>2017-11-14 06:16:37 +0200
commitb0bf5ef2925c18af4008501aa0717a7752cc5062 (patch)
tree247d643e2320d902d0b42f3d42167fdc5e50ffbc /Makefile.am
parentabbb33e38c22e8579351239075c5b632e28078ca (diff)
downloadopenvswitch-b0bf5ef2925c18af4008501aa0717a7752cc5062.tar.gz
installer-windows: Add x64 installer build via command line
Add a new variable to know on which platform we are compiling. Make the msbuild command to be aware of the platform we want to build. Shorter the msbuild parameters from `property:`->`p:`. Change slashes to double slashes so msys does not get confused. Signed-off-by: Alin Gabriel Serdean <aserdean@ovn.org> Acked-by: Alin Balutoiu <abalutoiu@cloudbasesolutions.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index ebbc0450e..5d19f0833 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -20,6 +20,7 @@ AM_CPPFLAGS += $(PTHREAD_INCLUDES)
AM_CPPFLAGS += $(MSVC_CFLAGS)
AM_LDFLAGS += $(PTHREAD_LDFLAGS)
AM_LDFLAGS += $(MSVC64_LDFLAGS)
+PLATFORM = $(MSVC_PLATFORM)
endif
AM_CPPFLAGS += -I $(top_srcdir)/include