summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorLance Richardson <lrichard@redhat.com>2016-01-08 13:19:16 -0500
committerRussell Bryant <russell@ovn.org>2016-01-08 13:22:22 -0500
commitb6429d8905a10697f10d1ed768edb28956ee712e (patch)
tree2c5e970fc6f6d24f1e4d7475803fecf82a995cf7 /Makefile.am
parente9ad9219994d60caa037d2288dbe27212407c562 (diff)
downloadopenvswitch-b6429d8905a10697f10d1ed768edb28956ee712e.tar.gz
python: ignore warnings from flake8 version 2.0
Ignore warnings emitted by flake8 version 2.0 (this is the version currently provided in the CentOS/RHEL 7 EPEL repository). Signed-off-by: Lance Richardson <lrichard@redhat.com> [russell@ovn.org Updated AUTHORS file] Signed-off-by: Russell Bryant <russell@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 4 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index ef921ee6f..253753250 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -343,17 +343,20 @@ endif
if HAVE_FLAKE8
ALL_LOCAL += flake8-check
# http://flake8.readthedocs.org/en/latest/warnings.html
+# E121 continuation line under-indented for hanging indent (only from flake8 v2.0)
# E123 closing bracket does not match indentation of opening bracket's line
+# E125 continuation line with same indent as next logical line (only from flake8 v2.0)
# E126 continuation line over-indented for hanging indent
# E127 continuation line over-indented for visual indent
# E128 continuation line under-indented for visual indent
# E129 visually indented line with same indent as next logical line
# E131 continuation line unaligned for hanging indent
+# F811 redefinition of unused <name> from line <N> (only from flake8 v2.0)
# W503 line break before binary operator
# D*** -- warnings from flake8-docstrings plugin
# H*** -- warnings from flake8 hacking plugin (custom style checks beyond PEP8)
flake8-check: $(FLAKE8_PYFILES)
- $(AM_V_GEN) if flake8 $^ --ignore=E123,E126,E127,E128,E129,E131,W503,D,H ${FLAKE8_FLAGS}; then touch $@; else exit 1; fi
+ $(AM_V_GEN) if flake8 $^ --ignore=E121,E123,E125,E126,E127,E128,E129,E131,F811,W503,D,H ${FLAKE8_FLAGS}; then touch $@; else exit 1; fi
endif
include $(srcdir)/manpages.mk