summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAaron Conole <aconole@redhat.com>2018-01-12 17:15:50 -0500
committerBen Pfaff <blp@ovn.org>2018-01-12 14:31:03 -0800
commitba2c7e014dafd64f45f57e7ea4dde6036c830262 (patch)
treeda34ee21edb6726ab208b46af5182382c6453294 /Makefile.am
parentcb12f42d88071efdecc7a3804ac5e2385349f70d (diff)
downloadopenvswitch-ba2c7e014dafd64f45f57e7ea4dde6036c830262.tar.gz
flake8: Ignore bare except violations
Newer versions of flake8 (3.5.0, mccabe: 0.6.1, pycodestyle: 2.3.1, pyflakes: 1.6.0) add an error code for 'bare exception'. The OvS codebase does use bare exceptions in places, especially when the specific exception isn't important (ie: the program will be terminating, so the specific exception isn't important). Without this change, the following error messages appear: utilities/checkpatch.py:476:5: E722 do not use bare except' utilities/checkpatch.py:514:5: E722 do not use bare except' utilities/ovs-dev.py:189:5: E722 do not use bare except' utilities/ovs-dev.py:192:9: E722 do not use bare except' utilities/ovs-dev.py:197:5: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:360:13: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:434:5: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:470:13: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:609:9: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:679:5: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:712:13: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:744:9: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:751:9: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:825:5: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:1006:13: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:1041:13: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:1079:5: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:1202:5: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:1247:9: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:1257:13: E722 do not use bare except' utilities/bugtool/ovs-bugtool.in:1328:9: E722 do not use bare except' tests/test-daemon.py:60:5: E722 do not use bare except' tests/test-l7.py:23:1: E722 do not use bare except' tests/test-unixctl.py:96:5: E722 do not use bare except' xenserver/usr_share_openvswitch_scripts_ovs-xapi-sync:404:5: E722 do not use bare except' python/ovs/fcntl_win.py:39:9: E722 do not use bare except' python/ovs/poller.py:38:1: E722 do not use bare except' python/ovs/socket_util.py:151:13: E722 do not use bare except' python/ovs/stream.py:169:17: E722 do not use bare except' python/ovs/stream.py:578:17: E722 do not use bare except' python/ovs/timeval.py:51:1: E722 do not use bare except' python/ovstest/util.py:52:5: E722 do not use bare except' vtep/ovs-vtep:767:5: E722 do not use bare except' Signed-off-by: Aaron Conole <aconole@redhat.com> Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index fca338bd7..ed4b7fd7c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -363,7 +363,7 @@ endif
if HAVE_FLAKE8
ALL_LOCAL += flake8-check
-# http://flake8.readthedocs.org/en/latest/warnings.html
+# http://flake8.readthedocs.org/en/latest/user/error-codes.html
# All warnings explicitly selected or ignored should be listed below.
#
# E***, W*** -- warnings from pep8
@@ -375,6 +375,7 @@ ALL_LOCAL += flake8-check
# E128 continuation line under-indented for visual indent
# E129 visually indented line with same indent as next logical line
# E131 continuation line unaligned for hanging indent
+# E722 do not use bare except, specify exception instead
# W503 line break before binary operator
# F*** -- warnings native to flake8
# F811 redefinition of unused <name> from line <N> (only from flake8 v2.0)
@@ -385,7 +386,7 @@ ALL_LOCAL += flake8-check
# H233 Python 3.x incompatible use of print operator
# H238 old style class declaration, use new style (inherit from `object`)
FLAKE8_SELECT = H231,H232,H233,H238
-FLAKE8_IGNORE = E121,E123,E125,E126,E127,E128,E129,E131,W503,F811,D,H,I
+FLAKE8_IGNORE = E121,E123,E125,E126,E127,E128,E129,E131,E722,W503,F811,D,H,I
flake8-check: $(FLAKE8_PYFILES)
$(FLAKE8_WERROR)$(AM_V_GEN) \
src='$^' && \