summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2018-01-11 15:49:24 -0800
committerBen Pfaff <blp@ovn.org>2018-01-12 10:46:50 -0800
commitd4042a708f08a79bb1f7501dec16607a6f602490 (patch)
tree34635219a99a6467cc338f30c68f7ffafb32792c /Makefile.am
parent2daae85a06d5e0038b94f9a6403bdbf2845ee7b6 (diff)
downloadopenvswitch-d4042a708f08a79bb1f7501dec16607a6f602490.tar.gz
configure: New --enable-sparse option to enable sparse checking by default.
Until now, "make" called sparse to do checking only if C=1 was passed on the command line. It was easy for developers to forget to specify that. This commit adds another option: specifying --enable-sparse on the configure command line enables sparse checking by default. (It can still be disabled with C=0.) Requested-by: Justin Pettit <jpettit@ovn.org> Signed-off-by: Ben Pfaff <blp@ovn.org> Acked-by: Justin Pettit <jpettit@ovn.org>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d7cfdcd52..fca338bd7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -129,6 +129,10 @@ check_SCRIPTS =
pkgconfig_DATA =
FLAKE8_PYFILES =
+if ENABLE_SPARSE_BY_DEFAULT
+C ?= 1
+endif
+
scriptsdir = $(pkgdatadir)/scripts
completiondir = $(sysconfdir)/bash_completion.d
pkgconfigdir = $(libdir)/pkgconfig