summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2017-11-20 09:40:45 -0800
committerBen Pfaff <blp@ovn.org>2017-11-26 16:12:07 -0800
commitde9872221647bf44179aff1adbb3e802e3c5b3db (patch)
tree07a37771e43419ece9c3d176b7b7f33dd8441ac1 /Makefile.am
parent74eaac06d61e918ce4bb82611c6f5905c77d94e4 (diff)
downloadopenvswitch-de9872221647bf44179aff1adbb3e802e3c5b3db.tar.gz
tests: Convert sodepends build tool from Perl to Python.
Perl is unfashionable and Python is more widely available and understood, so this commit converts one of the OVS uses of Perl into Python. Signed-off-by: Ben Pfaff <blp@ovn.org> Acked-by: Aaron Conole <aconole@redhat.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index f883fdc84..7448f1176 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -87,7 +87,7 @@ EXTRA_DIST = \
build-aux/calculate-schema-cksum \
build-aux/dist-docs \
build-aux/dpdkstrip.py \
- build-aux/sodepends.pl \
+ build-aux/sodepends.py \
build-aux/soexpand.py \
build-aux/xml2nroff \
$(MAN_FRAGMENTS) \
@@ -394,8 +394,8 @@ endif
CLEANFILES += flake8-check
include $(srcdir)/manpages.mk
-$(srcdir)/manpages.mk: $(MAN_ROOTS) build-aux/sodepends.pl
- @$(PERL) $(srcdir)/build-aux/sodepends.pl -I. -I$(srcdir) $(MAN_ROOTS) >$(@F).tmp
+$(srcdir)/manpages.mk: $(MAN_ROOTS) build-aux/sodepends.py python/build/soutil.py
+ @PYTHONPATH=$$PYTHONPATH:$(srcdir)/python $(PYTHON) $(srcdir)/build-aux/sodepends.py -I. -I$(srcdir) $(MAN_ROOTS) >$(@F).tmp
@if cmp -s $(@F).tmp $@; then \
touch $@; \
rm -f $(@F).tmp; \