summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2014-09-29 14:34:11 -0700
committerBen Pfaff <blp@nicira.com>2014-09-29 14:35:16 -0700
commitef44aa5001a4f6b06a4d65457d459bc004c37f48 (patch)
tree9f478651537b163d0bbf539a4e86d7a0984cd6bd /Makefile.am
parentddc3b06d348793ae3f858a832ce5c9053d7a621b (diff)
downloadopenvswitch-ef44aa5001a4f6b06a4d65457d459bc004c37f48.tar.gz
Makefiles: Add $(AM_V_GEN) annotations to clean up "make" output.
The Open vSwitch "make" output was still pretty verbose even when configured with --enable-silent-rules. This cleans it up. Signed-off-by: Ben Pfaff <blp@nicira.com> Acked-by: Joe Stringer <joestringer@nicira.com>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 4c48e73a9..56dada79a 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -137,7 +137,7 @@ ro_shell = printf '\043 Generated automatically -- do not modify! -*- buffer-
SUFFIXES += .in
.in:
- $(PERL) $(srcdir)/build-aux/soexpand.pl -I$(srcdir) < $< | \
+ $(AM_V_GEN)$(PERL) $(srcdir)/build-aux/soexpand.pl -I$(srcdir) < $< | \
sed \
-e 's,[@]PKIDIR[@],$(PKIDIR),g' \
-e 's,[@]LOGDIR[@],$(LOGDIR),g' \
@@ -156,7 +156,7 @@ SUFFIXES += .in
@if head -n 1 $@.tmp | grep '#!' > /dev/null; then \
chmod +x $@.tmp; \
fi
- $(AM_V_GEN) mv $@.tmp $@
+ $(AM_V_at) mv $@.tmp $@
.PHONY: clean-pycov
clean-pycov: