summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2018-06-14 14:49:23 -0700
committerBen Pfaff <blp@ovn.org>2018-08-15 11:02:22 -0700
commit0e12201039bf9edd5459110391b316da0c6991ed (patch)
tree03784a23026d2bb2d40b0f6cb6b25d314ae2d869 /configure.ac
parent6d917cd2bad1bfc1483f8cff7ef348fd30ed1a21 (diff)
downloadopenvswitch-0e12201039bf9edd5459110391b316da0c6991ed.tar.gz
configure: Enable GCC relevant new 8.x warning options.
These don't trigger any new actual warnings in my own build. GCC 8.x adds other new warning options that are enabled by -Wall or -Wextra. This commit doesn't explicitly enable those because OVS already enables -Wall and -Wextra. Signed-off-by: Ben Pfaff <blp@ovn.org> Acked-by: Aaron Conole <aconole@bytheb.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 09e5888d4..09464cab0 100644
--- a/configure.ac
+++ b/configure.ac
@@ -172,6 +172,8 @@ OVS_ENABLE_OPTION([-Wshift-negative-value])
OVS_ENABLE_OPTION([-Wduplicated-cond])
OVS_ENABLE_OPTION([-Qunused-arguments])
OVS_ENABLE_OPTION([-Wshadow])
+OVS_ENABLE_OPTION([-Wmultistatement-macros])
+OVS_ENABLE_OPTION([-Wcast-align=strict])
OVS_ENABLE_OPTION([-Wno-null-pointer-arithmetic])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])