summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorFlavio Leitner <fbl@redhat.com>2017-06-26 21:55:50 -0300
committerBen Pfaff <blp@ovn.org>2017-07-13 10:57:14 -0700
commit0eaaacac9488fd1746ba639314a502016059941e (patch)
tree399b440973bbf65f191ec3fb290cdfd238637993 /configure.ac
parente4713f24d5ee521e434acf53a9f36d3658c11a64 (diff)
downloadopenvswitch-0eaaacac9488fd1746ba639314a502016059941e.tar.gz
ctags: include symbols with locking annotations.
OVS uses extensively clang annotations for thread safety checks. The ctags tool can't parse them, so they are not included in the tag file. This patch improves the configure script to generate a list of identifiers from the header compiler.h to be ignored by ctags. Signed-off-by: Flavio Leitner <fbl@redhat.com> Signed-off-by: Ben Pfaff <blp@ovn.org> Reviewed-by: Aaron Conole <aconole@redhat.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ef6aad3a..23afe4c71 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,7 @@ OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
OVS_ENABLE_WERROR
OVS_ENABLE_SPARSE
+OVS_CTAGS_IDENTIFIERS
AC_ARG_VAR(KARCH, [Kernel Architecture String])
AC_SUBST(KARCH)