summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRichard Oliver <richard@richard-oliver.co.uk>2017-10-28 16:38:30 +0100
committerBen Pfaff <blp@ovn.org>2017-10-30 09:56:27 -0700
commit10fd9f6e477555ca93d28094c2976b2ea0198798 (patch)
tree168bb742fc48d1e0847e2dd9301bc5b2decf811a /configure.ac
parent45a9c31d5d915010deb6d8073fe22cf8c10f12de (diff)
downloadopenvswitch-10fd9f6e477555ca93d28094c2976b2ea0198798.tar.gz
timeval: Check for OS-provided clock_gettime on macOS
[Problem] Compilation error on newer versions of macOS (Sierra onwards) due to multiple declarations of clock_gettime. [Solution] Have configure check for clock_gettime and check this result in timeval to avoid incorrectly declaring/defining clock_gettime again. [Testing] Source code now successfully builds on macOS. Signed-off-by: Richard Oliver <richard@richard-oliver.co.uk> Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 27425991a..9e0081832 100644
--- a/configure.ac
+++ b/configure.ac
@@ -112,7 +112,7 @@ AC_CHECK_MEMBERS([struct mmsghdr.msg_len], [], [], [[#include <sys/socket.h>]])
AC_CHECK_MEMBERS([struct sockaddr_in6.sin6_scope_id], [], [],
[[#include <sys/socket.h>
#include <netinet/in.h>]])
-AC_CHECK_FUNCS([mlockall strnlen getloadavg statvfs getmntent_r sendmmsg])
+AC_CHECK_FUNCS([mlockall strnlen getloadavg statvfs getmntent_r sendmmsg clock_gettime])
AC_CHECK_HEADERS([mntent.h sys/statvfs.h linux/types.h linux/if_ether.h stdatomic.h])
AC_CHECK_HEADERS([net/if_mib.h], [], [], [[#include <sys/types.h>
#include <net/if.h>]])