summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAlin Serdean <aserdean@cloudbasesolutions.com>2015-09-23 17:30:32 +0000
committerGurucharan Shetty <gshetty@nicira.com>2015-09-29 11:17:42 -0700
commit1cb3649c0bbacf4f3cea353d02a5e1217b5294b4 (patch)
tree47ea041e4038d65bfa1d5c14984b2118037988f3 /configure.ac
parent34e1211b9a05d42a77cfac185361fc0539f77b21 (diff)
downloadopenvswitch-1cb3649c0bbacf4f3cea353d02a5e1217b5294b4.tar.gz
Add build system for compiling under MSVC x64
This patch adds the modifications needed to compile under x64 under Windows: - created a new macro for testing if we are compiling under x64. this will define the linker flag: "/MACHINE:X64" as per documentation (https://msdn.microsoft.com/en-us/library/9yb4317s.aspx). - added x64 pthread libraries under the pthread defines - add documentation on how to build under x64 Signed-off-by: Alin Gabriel Serdean <aserdean@cloudbasesolutions.com> Signed-off-by: Gurucharan Shetty <gshetty@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 36387a160..fd049291e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -85,6 +85,7 @@ AC_SEARCH_LIBS([pthread_create], [pthread])
AC_FUNC_STRERROR_R
OVS_CHECK_ESX
+OVS_CHECK_WIN64
OVS_CHECK_WIN32
OVS_CHECK_VISUAL_STUDIO_DDK
OVS_CHECK_COVERAGE