summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorVlad Buslov <vladbu@mellanox.com>2019-11-04 18:34:49 +0200
committerSimon Horman <simon.horman@netronome.com>2019-11-11 14:42:52 +0100
commit292d5bd9bb344527e0da19433cf3e51f8a24058c (patch)
tree944a9c08109601c218322292e5bf149abc6b63c7 /configure.ac
parentc0a1df2e3f209fbf3c61b66a719b90e41636ef52 (diff)
downloadopenvswitch-292d5bd9bb344527e0da19433cf3e51f8a24058c.tar.gz
tc: Set 'no_percpu' flag for compatible actions
Recent changes in Linux kernel TC action subsystem introduced new TCA_ACT_FLAGS_NO_PERCPU_STATS flag. The purpose of the flag is to request action implementation to skip allocating action stats with expensive percpu allocator and use regular built-in action stats instead. Such approach significantly improves rule insertion rate and reduce memory usage for hardware-offloaded rules that don't need benefits provided by percpu allocated stats (improved software TC fast-path performance). Set the flag for all compatible actions. Modify acinclude.m4 to use OVS-internal pkt_cls.h implementation when TCA_ACT_FLAGS is not defined by kernel headers and to manually define struct nla_bitfield32 in netlink.h (new file) when it is not defined by kernel headers. Signed-off-by: Vlad Buslov <vladbu@mellanox.com> Reviewed-by: Roi Dayan <roid@mellanox.com> Signed-off-by: Simon Horman <simon.horman@netronome.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 97d18685c..8abc1fdb5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,6 +186,7 @@ OVS_CTAGS_IDENTIFIERS
AC_ARG_VAR(KARCH, [Kernel Architecture String])
AC_SUBST(KARCH)
OVS_CHECK_LINUX
+OVS_CHECK_LINUX_NETLINK
OVS_CHECK_LINUX_TC
OVS_CHECK_LINUX_SCTP_CT
OVS_CHECK_DPDK