summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEthan Jackson <ethan@nicira.com>2012-10-05 13:24:21 -0700
committerEthan Jackson <ethan@nicira.com>2012-10-09 15:23:47 -0700
commit361906b1e2c6482d77280f345d3e42048d8c2700 (patch)
treebcd6efea6aea35a9c1e872ff68e230e2e9406ccc /configure.ac
parent2de795adb9632fc07ea49ced36eaa17c3f3fd106 (diff)
downloadopenvswitch-361906b1e2c6482d77280f345d3e42048d8c2700.tar.gz
config: Add explicit support for building on ESX.
The ESX userspace looks quite a bit like linux, but has some key differences which need to be specially handled in the build. To distinguish between ESX and systems which use the linux datapath module, this patch adds two new macros "ESX" and "LINUX_DATAPATH". It uses these macros to disable building code on ESX which only applies to a true Linux environment. In addition, it adds a new route-table-stub implementation which is required for the build to complete successfully on ESX. Signed-off-by: Ethan Jackson <ethan@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 9ec55486d..6fb30fd26 100644
--- a/configure.ac
+++ b/configure.ac
@@ -45,6 +45,7 @@ AC_SEARCH_LIBS([clock_gettime], [rt])
AC_SEARCH_LIBS([timer_create], [rt])
AC_SEARCH_LIBS([pcap_open_live], [pcap])
+OVS_CHECK_ESX
OVS_CHECK_COVERAGE
OVS_CHECK_NDEBUG
OVS_CHECK_NETLINK
@@ -112,4 +113,9 @@ AC_CONFIG_COMMANDS([include/openflow/openflow.h.stamp])
AC_CONFIG_COMMANDS([ovsdb/ovsdbmonitor/dummy], [:])
AC_CONFIG_COMMANDS([utilities/bugtool/dummy], [:])
+AM_CONDITIONAL([LINUX_DATAPATH], [test "$HAVE_NETLINK" = yes && test "$ESX" = no])
+if test "$HAVE_NETLINK" = yes && test "$ESX" = no; then
+ AC_DEFINE([LINUX_DATAPATH], [1], [System uses the linux datapath module.])
+fi
+
AC_OUTPUT