summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRussell Bryant <rbryant@redhat.com>2015-06-12 12:51:23 -0400
committerBen Pfaff <blp@nicira.com>2015-06-15 14:21:02 -0700
commit43d3e694152cb34f65b941a97b3741dd4d42462d (patch)
treec487a3c59cf56b90e9daa7b2be80706cd8040445 /configure.ac
parent6ad8ce88c31fde2d2938add9611205eef62a4141 (diff)
downloadopenvswitch-43d3e694152cb34f65b941a97b3741dd4d42462d.tar.gz
ovn: Add ovn-ctl to assist with OVN daemon lifecycle.
This patch introduces ovn-ctl, which is similar to ovs-ctl. I opted for a new script as everything in OVN so far is nicely isolated, so a new script seemed to make the most sense. If you'd like to run ovn-controller on a host already running ovs: # ovn-ctl start_controller If you'd like to run ovn-northd: # ovn-ctl start_northd Note that ovn-ctl assumes that ovn-northd is running on the same server as ovsdb-server hosting the OVN databases. Based on the current architecture this seems like a completely reasonable assumption. This can be improved later when needed. There's some additional stuff happening in start_northd to make the experience nicer and not require additional steps by the administrator. It creates the OVN dbs if they don't exist. If ovsdb-server hasn't loaded them, it tells it to load them, as well. ovn-ctl also supports running everything on the same host. This would be common in a test environment with a single host or small set of hosts. That would simply be: # ovs-ctl start --system-id=random # ovn-ctl start_northd # ovn-ctl start_controller Signed-off-by: Russell Bryant <rbryant@redhat.com> CC: Flavio Leitner <fbl@redhat.com> CC: Ben Pfaff <blp@nicira.com> [blp@nicira.com added configure.ac code to create ovn/utilities builddir] Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 666ab8fc8..c19c7c431 100644
--- a/configure.ac
+++ b/configure.ac
@@ -186,6 +186,7 @@ AC_CONFIG_COMMANDS([include/openflow/openflow.h.stamp])
AC_CONFIG_COMMANDS([utilities/bugtool/dummy], [:])
AC_CONFIG_COMMANDS([ovn/dummy], [:])
+AC_CONFIG_COMMANDS([ovn/utilities/dummy], [:])
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])