summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2015-04-19 01:48:06 +0800
committerBen Pfaff <blp@nicira.com>2015-04-20 10:58:43 -0700
commit513a32eea658ed86f3aaa3eda9f701d31d6fbcd6 (patch)
tree3852a6634d672fb42bd8de540d663ea03b0e6775 /configure.ac
parent96660ed1fc05ab5f76ef93d2c06f0746e1e93250 (diff)
downloadopenvswitch-513a32eea658ed86f3aaa3eda9f701d31d6fbcd6.tar.gz
configure.ac: Fix pthread linking on FreeBSD.
The configure script checks for the existence of pthread_sigmask. However, on FreeBSD, libc contains no-op stubs for many of the pthread_* functions. As a result, the AC_SEARCH_LIBS macro returns "none required". As an alternative to checking pthread_sigmask, a solution is to check pthread_create. Signed-off-by: Kevin Lo <kevlo@FreeBSD.org> Acked-by: YAMAMOTO Takashi <yamamoto@valinux.co.jp> Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 9615cb76e..068674ee7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,7 +81,7 @@ AC_SUBST([LT_AGE])
AC_SEARCH_LIBS([pow], [m])
AC_SEARCH_LIBS([clock_gettime], [rt])
AC_SEARCH_LIBS([timer_create], [rt])
-AC_SEARCH_LIBS([pthread_sigmask], [pthread])
+AC_SEARCH_LIBS([pthread_create], [pthread])
AC_FUNC_STRERROR_R
OVS_CHECK_ESX