summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2016-12-05 14:28:59 -0800
committerBen Pfaff <blp@ovn.org>2016-12-12 14:34:23 -0800
commit726af75275ba5575a6d3fd4013db4d1d930e5cf7 (patch)
tree23274e5641ca5c6072ffe7741376ddc2190048b1 /configure.ac
parent37f4615e91bedc139f60cb2bb771327a39ed9d8d (diff)
downloadopenvswitch-726af75275ba5575a6d3fd4013db4d1d930e5cf7.tar.gz
configure: Use -Wformat-security with -Wformat.
GCC 6.1 warns that -Wformat-security has no effect without -Wformat, so this commit fixes the problem. The change to _OVS_CHECK_CC_OPTION is needed so that the cache variable name doesn't end up with a space in it, which obviously doesn't work. Signed-off-by: Ben Pfaff <blp@ovn.org> Acked-by: Andy Zhou <azhou@ovn.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 2 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 2f854dd52..ece6bf327 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-# Copyright (c) 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015 Nicira, Inc.
+# Copyright (c) 2008, 2009, 2010, 2011, 2012, 2013, 2014, 2015, 2016 Nicira, Inc.
#
# Licensed under the Apache License, Version 2.0 (the "License");
# you may not use this file except in compliance with the License.
@@ -147,7 +147,7 @@ OVS_ENABLE_OPTION([-Wall])
OVS_ENABLE_OPTION([-Wextra])
OVS_ENABLE_OPTION([-Wno-sign-compare])
OVS_ENABLE_OPTION([-Wpointer-arith])
-OVS_ENABLE_OPTION([-Wformat-security])
+OVS_ENABLE_OPTION([-Wformat -Wformat-security])
OVS_ENABLE_OPTION([-Wswitch-enum])
OVS_ENABLE_OPTION([-Wunused-parameter])
OVS_ENABLE_OPTION([-Wbad-function-cast])