summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2018-08-15 10:38:09 -0700
committerIan Stokes <ian.stokes@intel.com>2018-08-27 17:48:23 +0100
commit89c09c1cd1f03506831105881ac29ffae74341f3 (patch)
tree3669dc12ab287e8fbecd31ef398d9addd0490815 /configure.ac
parent74cd69a479cc0e6056538e9f412a89b13752d237 (diff)
downloadopenvswitch-89c09c1cd1f03506831105881ac29ffae74341f3.tar.gz
netdev: Clean up class initialization.
The macros are hard to read. This makes it a little more readable. Signed-off-by: Ben Pfaff <blp@ovn.org> Signed-off-by: Ian Stokes <ian.stokes@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 09464cab0..ba9e7d66d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -175,6 +175,7 @@ OVS_ENABLE_OPTION([-Wshadow])
OVS_ENABLE_OPTION([-Wmultistatement-macros])
OVS_ENABLE_OPTION([-Wcast-align=strict])
OVS_ENABLE_OPTION([-Wno-null-pointer-arithmetic])
+OVS_ENABLE_OPTION([-Warray-bounds-pointer-arithmetic])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
OVS_ENABLE_WERROR