summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2016-12-05 14:38:08 -0800
committerBen Pfaff <blp@ovn.org>2016-12-12 14:34:34 -0800
commit905d453a87d63cb8b35ba7ac8fb8d9c82d8a2aa9 (patch)
treea353a0f3cba6801619aae6b445ba646c5f85bd35 /configure.ac
parent398b6657a6b9e534c2c4f99bc449083139b277ef (diff)
downloadopenvswitch-905d453a87d63cb8b35ba7ac8fb8d9c82d8a2aa9.tar.gz
configure: Enable new warning options added in GCC 6.
-Wnull-dereference is also new in GCC 6 but upon testing it produces far too many false positives to be usable for OVS. Signed-off-by: Ben Pfaff <blp@ovn.org> Acked-by: Andy Zhou <azhou@ovn.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index b3ade95e5..441423059 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,6 +162,8 @@ OVS_ENABLE_OPTION([-Wswitch-bool])
OVS_ENABLE_OPTION([-Wlogical-not-parentheses])
OVS_ENABLE_OPTION([-Wsizeof-array-argument])
OVS_ENABLE_OPTION([-Wbool-compare])
+OVS_ENABLE_OPTION([-Wshift-negative-value])
+OVS_ENABLE_OPTION([-Wduplicated-cond])
OVS_ENABLE_OPTION([-Qunused-arguments])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])