summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorThomas Graf <tgraf@noironetworks.com>2014-09-11 21:34:21 +0200
committerBen Pfaff <blp@nicira.com>2014-09-11 12:37:38 -0700
commit95626395a3dbd91b69af80207d79b3ecab7643c9 (patch)
tree4ddd2433f43dfdbcda14b935d15f2080f77558f6 /configure.ac
parent648cef14dd6775b38fb7b002d4d187a936bc8b6a (diff)
downloadopenvswitch-95626395a3dbd91b69af80207d79b3ecab7643c9.tar.gz
build: Respect CFLAGS and LDFLAGS passed to make
configure cannot expect that the user will not pass additional CFLAGS and LDFLAGS at make time [0]. Use OVS_CFLAGS and OVS_LDFLAGS instead to collect compiler and linker flags and substitute in Makefile.am. This allows for: ./configure --with-dpdk=[...] make CFLAGS=-Wno-error=foo [0] http://www.gnu.org/software/automake/manual/html_node/Flag-Variables-Ordering.html Signed-off-by: Thomas Graf <tgraf@noironetworks.com> Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index f1c9f9f31..35e884ab2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -122,6 +122,8 @@ AC_SUBST(KARCH)
OVS_CHECK_LINUX
OVS_CHECK_DPDK
OVS_CHECK_PRAGMA_MESSAGE
+AC_SUBST([OVS_CFLAGS])
+AC_SUBST([OVS_LDFLAGS])
AC_CONFIG_FILES(Makefile)
AC_CONFIG_FILES(datapath/Makefile)