summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIlya Maximets <i.maximets@ovn.org>2021-08-03 19:36:39 +0200
committerIlya Maximets <i.maximets@ovn.org>2021-08-05 11:46:33 +0200
commita3bd383e94a9ecfeeeed7b1b09cd5fee2328bf9c (patch)
tree60009994222e11e178c356a003ce24ca2a2ba3aa /configure.ac
parente21e9dcec24101648918e49e0b609106048e0850 (diff)
downloadopenvswitch-a3bd383e94a9ecfeeeed7b1b09cd5fee2328bf9c.tar.gz
acinclude: Don't set AVX512-related configuration via CFLAGS.
The correct way to pass configuration options is to define them inside the config.h. Additionally, few long lines wrapped and fixed the unnecessary double check for -mavx512f. Fixes: abb807e27dd4 ("dpif-netdev: Add command to switch dpif implementation.") Fixes: 5324b54e606a ("dpif-netdev: Add configure to enable autovalidator at build time.") Fixes: e90e115a01af ("dpif-netdev: implement subtable lookup validation.") Fixes: 352b6c7116cd ("dpif-lookup: add avx512 gather implementation.") Signed-off-by: Ilya Maximets <i.maximets@ovn.org> Acked-by: Cian Ferriter <cian.ferriter@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac4
1 files changed, 1 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 8ba09de21..eaa9bf7ee 100644
--- a/configure.ac
+++ b/configure.ac
@@ -179,15 +179,13 @@ OVS_ENABLE_OPTION([-Wno-null-pointer-arithmetic])
OVS_ENABLE_OPTION([-Warray-bounds-pointer-arithmetic])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
-OVS_CONDITIONAL_CC_OPTION([-mavx512f], [HAVE_AVX512F])
-OVS_CHECK_CC_OPTION([-mavx512f], [CFLAGS="$CFLAGS -DHAVE_AVX512F"])
OVS_ENABLE_WERROR
OVS_ENABLE_SPARSE
OVS_CTAGS_IDENTIFIERS
OVS_CHECK_DPCLS_AUTOVALIDATOR
OVS_CHECK_DPIF_AVX512_DEFAULT
OVS_CHECK_MFEX_AUTOVALIDATOR
-OVS_CHECK_BINUTILS_AVX512
+OVS_CHECK_AVX512
AC_ARG_VAR(KARCH, [Kernel Architecture String])
AC_SUBST(KARCH)