summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBen Pfaff <blp@ovn.org>2018-07-09 14:37:55 -0700
committerBen Pfaff <blp@ovn.org>2018-07-12 14:05:47 -0700
commita7021b08b0d554808f365f452481d327a6205044 (patch)
tree194b16838036e2ea5e6dddfc8ff87f2a8367ce61 /configure.ac
parent61b1c7acb9a209ec973c2a2a0d1126e5944845e8 (diff)
downloadopenvswitch-a7021b08b0d554808f365f452481d327a6205044.tar.gz
configure: Disable -Wnull-pointer-arithmetic Clang warning.
OVS trips over this warning all over the place, so it's not worth leaving on. Signed-off-by: Ben Pfaff <blp@ovn.org> Reviewed-by: Yifeng Sun <pkusunyifeng@gmail.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index af570b320..c89c607c7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -171,6 +171,7 @@ OVS_ENABLE_OPTION([-Wshift-negative-value])
OVS_ENABLE_OPTION([-Wduplicated-cond])
OVS_ENABLE_OPTION([-Qunused-arguments])
OVS_ENABLE_OPTION([-Wshadow])
+OVS_ENABLE_OPTION([-Wno-null-pointer-arithmetic])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
OVS_ENABLE_WERROR