summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorJustin Pettit <jpettit@ovn.org>2018-02-27 14:14:12 -0800
committerJustin Pettit <jpettit@ovn.org>2018-02-28 15:03:25 -0800
commitbc7284f56198636c2bace98bc3bc269da67a5fd1 (patch)
tree6f983878dba4748e1c38bdeca1b9587ee5e0e87d /configure.ac
parent396d492cfa8dcc6bb9b636a042d419b798e49264 (diff)
downloadopenvswitch-bc7284f56198636c2bace98bc3bc269da67a5fd1.tar.gz
Add -Wshadow for compilers that support it.
Signed-off-by: Justin Pettit <jpettit@ovn.org> Acked-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 84fed062c..9940a1a45 100644
--- a/configure.ac
+++ b/configure.ac
@@ -168,6 +168,7 @@ OVS_ENABLE_OPTION([-Wbool-compare])
OVS_ENABLE_OPTION([-Wshift-negative-value])
OVS_ENABLE_OPTION([-Wduplicated-cond])
OVS_ENABLE_OPTION([-Qunused-arguments])
+OVS_ENABLE_OPTION([-Wshadow])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
OVS_ENABLE_WERROR