summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYAMAMOTO Takashi <yamamoto@valinux.co.jp>2015-04-17 17:14:38 +0900
committerYAMAMOTO Takashi <yamamoto@valinux.co.jp>2015-04-20 11:20:58 +0900
commitc2deac545b68d2de5d9a3b966bafbb1c1993b8d3 (patch)
tree9939d7ae20c64e506850a92703f78004eee4bb53 /configure.ac
parentc84e499a2de8b029c651548092a46e3a1062990d (diff)
downloadopenvswitch-c2deac545b68d2de5d9a3b966bafbb1c1993b8d3.tar.gz
configure: Fix -Werror build for NetBSD + clang
On NetBSD, clang (clang-3.5.0 from pkgsrc) complains when "clang -g" is used for linking. Specify -Qunused-arguments to suppress the warning. Signed-off-by: YAMAMOTO Takashi <yamamoto@valinux.co.jp> Acked-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 62d26b04b..9615cb76e 100644
--- a/configure.ac
+++ b/configure.ac
@@ -155,6 +155,7 @@ OVS_ENABLE_OPTION([-Wmissing-prototypes])
OVS_ENABLE_OPTION([-Wmissing-field-initializers])
OVS_ENABLE_OPTION([-Wthread-safety])
OVS_ENABLE_OPTION([-fno-strict-aliasing])
+OVS_ENABLE_OPTION([-Qunused-arguments])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
OVS_ENABLE_WERROR