summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorAaron Conole <aconole@redhat.com>2017-01-16 14:06:27 -0500
committerBen Pfaff <blp@ovn.org>2017-01-18 14:19:49 -0800
commitcb991590239e1709f20ce3fc992a7b2f8cda5dc0 (patch)
tree4ad9821e52a222ad4b7a17e2c8174d10a5661a69 /configure.ac
parent3a77e83153b4a9cc2349b48b237ef37a17285038 (diff)
downloadopenvswitch-cb991590239e1709f20ce3fc992a7b2f8cda5dc0.tar.gz
libX: add new release / version info tags
This commit uses the $PACKAGE_VERSION automake variable to construct a release and version info combination which sets the library name to be: libfoo-$(OVS_MAJOR_VERSION).so.$(OVS_MINOR_VERSION).0.$(OVS_MICRO_VERSION) where formerly, it was always: libfoo.so.1.0.0 This allows releases of Open vSwitch libraries to reflect which specific versions they came with, and sets up a psuedo ABI-versioning scheme. In this fashion, future releases of Open vSwitch could be installed alongside older releases, allowing 3rd party utilities linked against previous versions to continue to function. ex: $ ldd /path/to/utility linux-vdso.so.1 (0x00007ffe92cf6000) libopenvswitch-2.so.6 => /lib64/libopenvswitch-2.so.6 (0x00007f733b7a3000) libssl.so.10 => /lib64/libssl.so.10 (0x00007f733b530000) ... Note the library name and version information. Signed-off-by: Aaron Conole <aconole@redhat.com> Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index a9ae2a11a..7c729ef49 100644
--- a/configure.ac
+++ b/configure.ac
@@ -131,6 +131,7 @@ OVS_CHECK_ATOMIC_ALWAYS_LOCK_FREE(8)
OVS_CHECK_POSIX_AIO
OVS_CHECK_PTHREAD_SET_NAME
OVS_CHECK_LINUX_HOST
+OVS_LIBTOOL_VERSIONS
AX_FUNC_POSIX_MEMALIGN
OVS_CHECK_INCLUDE_NEXT([stdio.h string.h])