summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorHarry van Haaren <harry.van.haaren@intel.com>2020-07-13 13:42:10 +0100
committerIan Stokes <ian.stokes@intel.com>2020-07-13 14:54:08 +0100
commite90e115a01afe7001863582b65fdaa278794e610 (patch)
treef357e7ab391ecd8cae3f3ec1140b03faaab4e351 /configure.ac
parentfa31efd211143f1adb06a62faad803a5aca1e400 (diff)
downloadopenvswitch-e90e115a01afe7001863582b65fdaa278794e610.tar.gz
dpif-netdev: implement subtable lookup validation.
This commit refactors the existing dpif subtable function pointer infrastructure, and implements an autovalidator component. The refactoring of the existing dpcls subtable lookup function handling, making it more generic, and cleaning up how to enable more implementations in future. In order to ensure all implementations provide identical results, the autovalidator is added. The autovalidator itself implements the subtable lookup function prototype, but internally iterates over all other available implementations. The end result is that testing of each implementation becomes automatic, when the auto- validator implementation is selected. Signed-off-by: Harry van Haaren <harry.van.haaren@intel.com> Acked-by: William Tu <u9012063@gmail.com> Signed-off-by: Ian Stokes <ian.stokes@intel.com>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac1
1 files changed, 1 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 5ce510c20..4a6995ea8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -181,6 +181,7 @@ OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
OVS_ENABLE_WERROR
OVS_ENABLE_SPARSE
OVS_CTAGS_IDENTIFIERS
+OVS_CHECK_DPCLS_AUTOVALIDATOR
AC_ARG_VAR(KARCH, [Kernel Architecture String])
AC_SUBST(KARCH)