summaryrefslogtreecommitdiff
path: root/debian/control
diff options
context:
space:
mode:
authorYifeng Sun <pkusunyifeng@gmail.com>2018-06-26 14:06:21 -0700
committerBen Pfaff <blp@ovn.org>2018-07-06 13:50:00 -0700
commit771680d96fb6f996987630cb85bb749478512268 (patch)
treee3fddb4c770f88e405fd82787933216fc5b1ac58 /debian/control
parentdef5b366a3626fddc87a449e8447f79a6957d55f (diff)
downloadopenvswitch-771680d96fb6f996987630cb85bb749478512268.tar.gz
DNS: Add basic support for asynchronous DNS resolving
This patch is a simple implementation for the proposal discussed in https://mail.openvswitch.org/pipermail/ovs-dev/2017-August/337038.html and https://mail.openvswitch.org/pipermail/ovs-dev/2017-October/340013.html. It enables ovs-vswitchd and other utilities to use DNS names when specifying OpenFlow and OVSDB remotes. Below are some of the features and limitations of this patch: - Resolving is asynchornous in daemon context, avoiding blocking main loop; - Resolving is synchronous in general utility context; - Both IPv4 and IPv6 are supported; - The resolving API is thread-safe; - Depends on the unbound library; - When multiple ip addresses are returned, only the first one is used; - /etc/nsswitch.conf isn't respected as unbound library doesn't look at it; - For async-resolving, caller need to retry later; there is no callback. Signed-off-by: Yifeng Sun <pkusunyifeng@gmail.com> Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control4
1 files changed, 3 insertions, 1 deletions
diff --git a/debian/control b/debian/control
index a4c031d85..9ae248f27 100644
--- a/debian/control
+++ b/debian/control
@@ -16,7 +16,8 @@ Build-Depends: graphviz,
python-all (>= 2.7),
python-twisted-conch,
python-zopeinterface,
- python-six
+ python-six,
+ libunbound-dev
Standards-Version: 3.9.3
Homepage: http://openvswitch.org/
@@ -307,6 +308,7 @@ Multi-Arch: same
Depends:
libopenvswitch (>= ${binary:Version}),
libssl-dev,
+ libunbound-dev,
${misc:Depends}
Conflicts: openvswitch-dev
Replaces: openvswitch-dev