summaryrefslogtreecommitdiff
path: root/debian/rules.modules
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2010-08-05 10:59:26 -0700
committerBen Pfaff <blp@nicira.com>2010-08-11 16:16:55 -0700
commit3d41239d308452b43bdf64d8acf7dde20e0fb986 (patch)
treea53901674203f32d0cb1ab4f076af9baa1cdee58 /debian/rules.modules
parente519ea28d6da56330a46c5b1d7c3ad84a6c45536 (diff)
downloadopenvswitch-3d41239d308452b43bdf64d8acf7dde20e0fb986.tar.gz
debian: Use dh_installmodules instead of calling "depmod" wrongly.
Until now, the postinst for kernel modules built by the Debian packaging has simply run "depmod -a", which is wrong, since this command rebuilds the dependencies for the *running* kernel, which is not necessarily the kernel for which modules are being installed. The dh_installmodules script automatically adds the correct invocation of depmod to the postinst script, so this commit switches to using that instead. This commit moves the kernel modules from /lib/modules/$KVERS into the "kernel" subdirectory of that directory because dh_installmodules does not support modules that are directly in the $KVERS directory. CC: Sajjad Lateef <slateef@nicira.com>
Diffstat (limited to 'debian/rules.modules')
-rwxr-xr-xdebian/rules.modules3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/rules.modules b/debian/rules.modules
index 4f39ceed7..4ca3d9285 100755
--- a/debian/rules.modules
+++ b/debian/rules.modules
@@ -20,7 +20,7 @@ kdist_clean:
kdist_config: prep-deb-files
.PHONY: binary-modules
-binary-modules: DSTDIR = $(CURDIR)/debian/$(PKGNAME)/lib/modules/$(KVERS)
+binary-modules: DSTDIR = $(CURDIR)/debian/$(PKGNAME)/lib/modules/$(KVERS)/kernel
binary-modules: prep-deb-files
dh_testdir
dh_testroot
@@ -30,6 +30,7 @@ binary-modules: prep-deb-files
cd openvswitch && $(MAKE) -C datapath/linux-2.6
install -d -m755 $(DSTDIR)
install -m644 openvswitch/datapath/linux-2.6/*_mod.ko $(DSTDIR)/
+ dh_installmodules
dh_installdocs
dh_installchangelogs
dh_compress