summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2015-06-07 09:48:14 -0700
committerBen Pfaff <blp@nicira.com>2015-06-10 09:19:39 -0700
commit40e7cf5607052d3b4fa09fd433fa630352c115b6 (patch)
tree4480696260487d892a041a299f5d6820c7556f2d /debian
parentbdd7ecf5bfc4a255872aa60057b3b96f72b47d8a (diff)
downloadopenvswitch-40e7cf5607052d3b4fa09fd433fa630352c115b6.tar.gz
configure: Stop avoiding -Wformat-zero-length.
Debian likes to enable -Wformat-zero-length, even over our code trying to disable it. It isn't too hard to make our code warning-free against this option, so this commit both stops disabling it and fixes the warnings. The first fix is to change set_subprogram_name() to take a plain string instead of a format string, and to adjust its few callers. This fixes one warning since one of those callers passed in an empty string. The second fix is to remove a test for ovs_scan() against an empty string. I couldn't find a way to avoid a warning for this test, and it isn't too valuable in any case. This allows us to drop filtering for -Wformat from the Debian rules file, so this commit removes it. Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 0 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index fc6ce57eb..38ecd6227 100755
--- a/debian/rules
+++ b/debian/rules
@@ -35,13 +35,6 @@ endif
buildflags := $(shell if dpkg-buildflags --export=configure >/dev/null 2>&1; \
then dpkg-buildflags --export=configure; fi)
-# dpkg-buildflags tends to turn on -Wformat, which is admirable, but
-# the -Wformat-zero-length subset of that option triggers a couple of
-# false positives in Open vSwitch so turn it right back off again.
-# (We do this in configure.ac also, but the Debian buildflags override
-# those.)
-buildflags := $(patsubst -Wformat,-Wformat -Wno-format-zero-length,$(buildflags))
-
configure: configure-stamp
configure-stamp:
dh_testdir