summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2011-01-07 09:35:19 -0800
committerBen Pfaff <blp@nicira.com>2011-01-07 09:35:19 -0800
commit59405f317bf13896161d13eb485077f0b33154e7 (patch)
treee3539af53ec106e1a871518ef7fff09f38f63e7f /debian
parenta0d8d6973b514143c41c202327f80a8bf27aee11 (diff)
downloadopenvswitch-59405f317bf13896161d13eb485077f0b33154e7.tar.gz
debian: Update check for Debian package version.
A version number like "1.1.0pre2" is properly translated into a Debian version number as "1.1.0~pre2", so we need to make that translation. Also, the Debian version number will often have suffixes on it, so don't check for a trailing parenthesis.
Diffstat (limited to 'debian')
-rw-r--r--debian/automake.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/debian/automake.mk b/debian/automake.mk
index f49310014..c6e584a07 100644
--- a/debian/automake.mk
+++ b/debian/automake.mk
@@ -43,12 +43,13 @@ EXTRA_DIST += \
debian/rules.modules
check-debian-changelog-version:
- @if $(FGREP) '($(VERSION))' $(srcdir)/debian/changelog >/dev/null; \
- then \
- :; \
- else \
- echo "Update debian/changelog to mention version $(VERSION)"; \
- exit 1; \
+ @DEB_VERSION=`echo '$(VERSION)' | sed 's/pre/~pre/'`; \
+ if $(FGREP) '($(DEB_VERSION)' $(srcdir)/debian/changelog >/dev/null; \
+ then \
+ :; \
+ else \
+ echo "Update debian/changelog to mention version $(VERSION)"; \
+ exit 1; \
fi
ALL_LOCAL += check-debian-changelog-version
DIST_HOOKS += check-debian-changelog-version