summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorAdrian Moreno <amorenoz@redhat.com>2022-07-08 20:03:08 +0200
committerIlya Maximets <i.maximets@ovn.org>2022-07-15 20:14:24 +0200
commit7e588e82f0663d0ef8ff777df8bc7111cc215657 (patch)
tree7002e602a586cf269defdf953997abfc4f9be25a /debian
parent076663b31edca55ec62120200bbc07d09d1af720 (diff)
downloadopenvswitch-7e588e82f0663d0ef8ff777df8bc7111cc215657.tar.gz
python: Add flow filtering syntax.
Based on pyparsing, create a very simple filtering syntax. It supports basic logic statements (and, &, or, ||, not, !), numerical operations (<, >), equality (=, !=), and masking (~=). The latter is only supported in certain fields (IntMask, EthMask, IPMask). Masking operation is semantically equivalent to "includes", therefore: ip_src ~= 192.168.1.1 means that ip_src field is either a host IP address equal to 192.168.1.1 or an IPMask that includes it (e.g: 192.168.1.1/24). Acked-by: Eelco Chaudron <echaudro@redhat.com> Signed-off-by: Adrian Moreno <amorenoz@redhat.com> Signed-off-by: Ilya Maximets <i.maximets@ovn.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/control.in3
1 files changed, 2 insertions, 1 deletions
diff --git a/debian/control.in b/debian/control.in
index f97124e07..db52c8a99 100644
--- a/debian/control.in
+++ b/debian/control.in
@@ -285,7 +285,8 @@ Depends:
${python3:Depends},
${shlibs:Depends},
Suggests:
- python3-netaddr
+ python3-netaddr,
+ python3-pyparsing,
Description: Python 3 bindings for Open vSwitch
Open vSwitch is a production quality, multilayer, software-based,
Ethernet virtual switch. It is designed to enable massive network