summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Pfaff <blp@nicira.com>2014-08-26 08:56:09 -0700
committerBen Pfaff <blp@nicira.com>2014-08-26 08:57:13 -0700
commit83c88c26235c7004eaf9b415f609ad0b30001236 (patch)
treee4a0bbdb7f1e5c23bcf1dc49ee2521beb839d295 /debian
parente3eb6585674d2300496c0311076c8cbd6a6c82bc (diff)
downloadopenvswitch-83c88c26235c7004eaf9b415f609ad0b30001236.tar.gz
debian: Really fix packaging given new dot-files.
commit a5c1096abb1 (debian: Fix debian packaging build failures due to dot-files in tree.) contained an error that I've made before and should have noticed. This commit should really fix the problem. Signed-off-by: Ben Pfaff <blp@nicira.com>
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules2
1 files changed, 1 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index fd9b1b851..d9a928794 100755
--- a/debian/rules
+++ b/debian/rules
@@ -103,7 +103,7 @@ install-indep: build-indep
dh_installdirs -p$(pdkms) usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)
# copy the source
- cd debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION) && tar xvzf $(CURDIR)/_debian/openvswitch.tar.gz && mv openvswitch/* openvswitch/.* . && rmdir openvswitch
+ cd debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION) && tar xvzf $(CURDIR)/_debian/openvswitch.tar.gz && mv openvswitch/* openvswitch/.[a-z]* . && rmdir openvswitch
# Prepare dkms.conf from the dkms.conf.in template
sed "s/__VERSION__/$(DEB_UPSTREAM_VERSION)/g" debian/dkms.conf.in > debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/dkms.conf