summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorBen Warren <ben@skyportsystems.com>2017-06-08 13:47:02 -0700
committerBen Pfaff <blp@ovn.org>2017-06-14 14:02:25 -0700
commitc33e9122dbc369e6bbe6dc3b1ebdcb11b56cdf07 (patch)
treed741fcd7642180781c87fd3b9236fa73d31190ff /debian
parenta1fccabce2cb2a9d5cc1b31fa2bc61b3613984ce (diff)
downloadopenvswitch-c33e9122dbc369e6bbe6dc3b1ebdcb11b56cdf07.tar.gz
Debian: Rework libopenvswitch packages
The 'openvswitch-common' package did not work well with cross-compiling since it required Python. This package is broken into two packages as follows: - libopenvwitch: contains library files (.a, .so) - openvswitch-common: depends on libopenvswitch, contains command-line tools such as ovs-ofctl, ovs-appctl etc. In addition, this 'openvswitch-dev' library is renamed to 'libopenvswitch-dev' to align more closely with Debian policy. It depends on libopenvswitch. Signed-off-by: Ben Warren <ben@skyportsystems.com> Signed-off-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'debian')
-rw-r--r--debian/.gitignore4
-rw-r--r--debian/automake.mk3
-rw-r--r--debian/control23
-rw-r--r--debian/libopenvswitch-dev.install (renamed from debian/openvswitch-dev.install)0
-rw-r--r--debian/libopenvswitch.install1
-rw-r--r--debian/openvswitch-common.install1
6 files changed, 27 insertions, 5 deletions
diff --git a/debian/.gitignore b/debian/.gitignore
index 4baed48e1..9ec70eb9c 100644
--- a/debian/.gitignore
+++ b/debian/.gitignore
@@ -6,6 +6,8 @@
/control
/copyright
/files
+/libopenvswitch
+/libopenvswitch-dev
/nicira-switch
/openvswitch
/openvswitch-common
@@ -13,7 +15,6 @@
/openvswitch-datapath-source
/openvswitch-datapath-dkms
/openvswitch-dbg
-/openvswitch-dev
/openvswitch-ipsec
/openvswitch-pki
/openvswitch-switch
@@ -22,6 +23,7 @@
/openvswitch-testcontroller
/openvswitch-vtep
/ovn-common
+/ovn-controller-vtep
/ovn-host
/ovn-central
/ovn-docker
diff --git a/debian/automake.mk b/debian/automake.mk
index 07ea912c4..4d8e204bb 100644
--- a/debian/automake.mk
+++ b/debian/automake.mk
@@ -7,6 +7,8 @@ EXTRA_DIST += \
debian/copyright.in \
debian/dkms.conf.in \
debian/dirs \
+ debian/libopenvswitch.install \
+ debian/libopenvswitch-dev.install \
debian/openvswitch-common.dirs \
debian/openvswitch-common.docs \
debian/openvswitch-common.install \
@@ -18,7 +20,6 @@ EXTRA_DIST += \
debian/openvswitch-datapath-source.copyright \
debian/openvswitch-datapath-source.dirs \
debian/openvswitch-datapath-source.install \
- debian/openvswitch-dev.install \
debian/openvswitch-pki.dirs \
debian/openvswitch-pki.postinst \
debian/openvswitch-pki.postrm \
diff --git a/debian/control b/debian/control
index 0b75f2b53..42e6f16d5 100644
--- a/debian/control
+++ b/debian/control
@@ -59,6 +59,7 @@ Architecture: linux-any
Depends: openssl,
python (>= 2.7),
python-six,
+ libopenvswitch (= ${binary:Version}),
${misc:Depends},
${shlibs:Depends}
Suggests: ethtool
@@ -76,6 +77,22 @@ Description: Open vSwitch common components
openvswitch-common provides components required by both openvswitch-switch
and openvswitch-testcontroller.
+Package: libopenvswitch
+Architecture: linux-any
+Depends: libssl-dev,
+ ${misc:Depends},
+ ${shlibs:Depends}
+Description: Open vSwitch common components
+ Open vSwitch is a production quality, multilayer, software-based,
+ Ethernet virtual switch. It is designed to enable massive network
+ automation through programmatic extension, while still supporting
+ standard management interfaces and protocols (e.g. NetFlow, IPFIX,
+ sFlow, SPAN, RSPAN, CLI, LACP, 802.1ag). In addition, it is designed
+ to support distribution across multiple physical servers similar to
+ VMware's vNetwork distributed vswitch or Cisco's Nexus 1000V.
+ .
+ libopenvswitch provides runtime libraries for use by openvswitch binaries
+
Package: openvswitch-switch
Architecture: linux-any
Suggests: openvswitch-datapath-module
@@ -283,11 +300,13 @@ Description: Open vSwitch VTEP utilities
This package provides utilities that are useful to interact with a
VTEP-configured database and a VTEP emulator.
-Package: openvswitch-dev
+Package: libopenvswitch-dev
Architecture: linux-any
Depends:
- openvswitch-common (>= ${binary:Version}),
+ libopenvswitch (>= ${binary:Version}),
${misc:Depends}
+Conflicts: openvswitch-dev
+Replaces: openvswitch-dev
Description: Open vSwitch development package
Open vSwitch is a production quality, multilayer, software-based, Ethernet
virtual switch. It is designed to enable massive network automation through
diff --git a/debian/openvswitch-dev.install b/debian/libopenvswitch-dev.install
index 11791e41e..11791e41e 100644
--- a/debian/openvswitch-dev.install
+++ b/debian/libopenvswitch-dev.install
diff --git a/debian/libopenvswitch.install b/debian/libopenvswitch.install
new file mode 100644
index 000000000..d0dbfd18a
--- /dev/null
+++ b/debian/libopenvswitch.install
@@ -0,0 +1 @@
+usr/lib/lib*.so.*
diff --git a/debian/openvswitch-common.install b/debian/openvswitch-common.install
index ebb7d5c1a..3264ea53c 100644
--- a/debian/openvswitch-common.install
+++ b/debian/openvswitch-common.install
@@ -9,4 +9,3 @@ usr/sbin/ovs-bugtool
usr/share/openvswitch/bugtool-plugins
usr/share/openvswitch/scripts/ovs-bugtool-*
usr/share/openvswitch/scripts/ovs-lib
-usr/lib/lib*.so.*