summaryrefslogtreecommitdiff
path: root/python/setup.py
diff options
context:
space:
mode:
authorTerry Wilson <twilson@redhat.com>2015-07-29 21:12:45 -0500
committerRussell Bryant <russell@ovn.org>2016-01-12 11:47:33 -0500
commit3ab76c56d88bcdb5d3993ed8c793312a754b7315 (patch)
tree11ed233d584279a5c3d949b8e90f5f0a887d094f /python/setup.py
parentab2a3154f09e5b97d66dfff125daf1ee265f30f4 (diff)
downloadopenvswitch-3ab76c56d88bcdb5d3993ed8c793312a754b7315.tar.gz
python: Start fixing some Python 3 issues.
This patch fixes just the Python 3 problems found by running: python3 setup.py install There are still many other issues to be fixed, but this is a start. Signed-off-by: Terry Wilson <twilson@redhat.com> [russell@ovn.org resolved conflicts with current master] Signed-off-by: Russell Bryant <russell@ovn.org> Acked-by: Ben Pfaff <blp@ovn.org>
Diffstat (limited to 'python/setup.py')
-rw-r--r--python/setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/python/setup.py b/python/setup.py
index 889d21594..62507ad05 100644
--- a/python/setup.py
+++ b/python/setup.py
@@ -19,7 +19,7 @@ VERSION = "unknown"
try:
# Try to set the version from the generated ovs/version.py
- execfile("ovs/version.py")
+ exec(open("ovs/version.py").read())
except IOError:
print("Ensure version.py is created by running make python/ovs/version.py",
file=sys.stderr)