summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 4 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index 6b28a5262..70e3ab829 100644
--- a/configure.ac
+++ b/configure.ac
@@ -60,7 +60,7 @@ m4_pattern_forbid([LT_INIT]) dnl Make autoconf fail if libtool is missing.
# replacement, but programs using the new version may use APIs not
# present in the previous one. In other words, new symbols have been
# added and a program linking against the new version may fail with
-# “unresolved symbols.” If linking against the old version at runtime:
+# "unresolved symbols." If linking against the old version at runtime:
# set revision to 0, bump current and age.
#
# 3. Programs may need to be changed, recompiled, relinked in order to use
@@ -81,7 +81,7 @@ AC_SUBST([LT_AGE])
AC_SEARCH_LIBS([pow], [m])
AC_SEARCH_LIBS([clock_gettime], [rt])
AC_SEARCH_LIBS([timer_create], [rt])
-AC_SEARCH_LIBS([pthread_sigmask], [pthread])
+AC_SEARCH_LIBS([pthread_create], [pthread])
AC_FUNC_STRERROR_R
OVS_CHECK_ESX
@@ -111,6 +111,7 @@ OVS_CHECK_PKIDIR
OVS_CHECK_RUNDIR
OVS_CHECK_DBDIR
OVS_CHECK_BACKTRACE
+OVS_CHECK_PERF_EVENT
OVS_CHECK_VALGRIND
OVS_CHECK_SOCKET_LIBS
OVS_CHECK_XENSERVER_VERSION
@@ -155,6 +156,7 @@ OVS_ENABLE_OPTION([-Wmissing-prototypes])
OVS_ENABLE_OPTION([-Wmissing-field-initializers])
OVS_ENABLE_OPTION([-Wthread-safety])
OVS_ENABLE_OPTION([-fno-strict-aliasing])
+OVS_ENABLE_OPTION([-Qunused-arguments])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused], [HAVE_WNO_UNUSED])
OVS_CONDITIONAL_CC_OPTION([-Wno-unused-parameter], [HAVE_WNO_UNUSED_PARAMETER])
OVS_ENABLE_WERROR