summaryrefslogtreecommitdiff
path: root/Makefile
diff options
context:
space:
mode:
authorSimon Kelley <simon@thekelleys.org.uk>2013-10-02 11:44:59 +0100
committerSimon Kelley <simon@thekelleys.org.uk>2013-10-02 11:48:43 +0100
commitb7f666ff0914b949661506129d78c20ca4987423 (patch)
tree92ebedf291a8daccf4f83e3f4d0745f043873070 /Makefile
parente4e9b342a7d6d8d8746d5d79cad9f6abb10b67a6 (diff)
downloaddnsmasq-b7f666ff0914b949661506129d78c20ca4987423.tar.gz
Add *.po target to cannonicalise .po files received from translators.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile5
1 files changed, 5 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index b4178bc..be809d5 100644
--- a/Makefile
+++ b/Makefile
@@ -114,6 +114,11 @@ merge :
echo -n msgmerge $(PO)/$$f && $(MSGMERGE) --no-wrap -U $(PO)/$$f $(BUILDDIR)/dnsmasq.pot; \
done
+# Cannonicalise .po file.
+%.po :
+ @cd $(BUILDDIR) && $(MAKE) -f $(top)/Makefile dnsmasq.pot
+ mv $(PO)/$*.po $(PO)/$*.po.orig && $(MSGMERGE) --no-wrap $(PO)/$*.po.orig $(BUILDDIR)/dnsmasq.pot >$(PO)/$*.po;
+
$(BUILDDIR):
mkdir -p $(BUILDDIR)