summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSimon Kelley <simon@thekelleys.org.uk>2017-06-05 20:50:04 +0100
committerSimon Kelley <simon@thekelleys.org.uk>2017-06-05 20:50:54 +0100
commit109d0e74f1937c1051dc392e3bbd17ea4ae3faa1 (patch)
tree68968098e8289f8829849013c654d8dca7dcdb12 /debian
parent74ea91531a5f0c6ad8c4bcc5f6bda55bf2c2acb1 (diff)
downloaddnsmasq-109d0e74f1937c1051dc392e3bbd17ea4ae3faa1.tar.gz
Debian: improve regexp for parsing root.ds.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rw-r--r--debian/init2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 36f18a6..d19a1d0 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dnsmasq (2.77-2) unstable; urgency=low
+
+ * Improve sed regexp for parsing root.ds.
+
+ -- Simon Kelley <simon@thekelleys.org.uk> Mon, 5 Jun 2017 20:46:32 +0000
+
dnsmasq (2.77-1) unstable; urgency=low
* New upstream.
diff --git a/debian/init b/debian/init
index 49556ad..9b10c38 100644
--- a/debian/init
+++ b/debian/init
@@ -111,7 +111,7 @@ DNSMASQ_OPTS="$DNSMASQ_OPTS --local-service"
ROOT_DS="/usr/share/dns/root.ds"
if [ -f $ROOT_DS ]; then
- DNSMASQ_OPTS="$DNSMASQ_OPTS `sed -e s/"^.*DS[\t ]"/--trust-anchor=.,/ -e s/" "/,/g $ROOT_DS | tr '\n' ' '`"
+ DNSMASQ_OPTS="$DNSMASQ_OPTS `sed -rne "s/^([.a-ZA-Z0-9]+)([[:space:]]+[0-9]+)*([[:space:]]+IN)*[[:space:]]+DS[[:space:]]+/--trust-anchor=\1,/;s/[[:space:]]+/,/gp" $ROOT_DS | tr '\n' ' '`"
fi
start()