summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorSimon Kelley <simon@thekelleys.org.uk>2020-06-26 22:13:27 +0100
committerSimon Kelley <simon@thekelleys.org.uk>2020-06-26 22:13:27 +0100
commit837e8f4eb550c688e8a83415c42a99c7bf9a4311 (patch)
tree2de05fe5f4293eb3513ad25edb713fd62303c1cc /debian
parente2cb6559586d4b0d0087c326eac0129fe8661382 (diff)
downloaddnsmasq-837e8f4eb550c688e8a83415c42a99c7bf9a4311.tar.gz
Remove runit support when building debs for Ubuntu.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog6
-rwxr-xr-xdebian/rules12
2 files changed, 13 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 4606d33..b2ec6fc 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+dnsmasq (2.81-4) unstable; urgency=low
+
+ * Remove runit support when building for Ubuntu. (closes: #960401)
+
+ -- Simon Kelley <simon@thekelleys.org.uk> Fri, 26 Jun 2020 21:52:44 +0000
+
dnsmasq (2.81-3) unstable; urgency=low
* Fixes to control file for bug 958100
diff --git a/debian/rules b/debian/rules
index ae8fcb2..8d634a3 100755
--- a/debian/rules
+++ b/debian/rules
@@ -177,11 +177,13 @@ binary-indep: checkroot
-d debian/trees/daemon/etc/insserv.conf.d
install -m 644 debian/conffiles debian/trees/daemon/DEBIAN
install -m 755 debian/postinst debian/postrm debian/prerm debian/trees/daemon/DEBIAN
- rm -f debian/dnsmasq.postinst.debhelper debian/dnsmasq.postrm.debhelper
- dh_runit -pdnsmasq -Pdebian/trees/daemon
- cd debian/trees/daemon && find etc/sv -type f -printf '/%p\n' >>DEBIAN/conffiles
- cat debian/dnsmasq.postinst.debhelper >> debian/trees/daemon/DEBIAN/postinst
- cat debian/dnsmasq.postrm.debhelper >> debian/trees/daemon/DEBIAN/postrm
+ if ! dpkg-vendor --derives-from Ubuntu; then \
+ rm -f debian/dnsmasq.postinst.debhelper debian/dnsmasq.postrm.debhelper; \
+ dh_runit -pdnsmasq -Pdebian/trees/daemon; \
+ cat debian/dnsmasq.postinst.debhelper >> debian/trees/daemon/DEBIAN/postinst; \
+ cat debian/dnsmasq.postrm.debhelper >> debian/trees/daemon/DEBIAN/postrm; \
+ cd debian/trees/daemon && find etc/sv -type f -printf '/%p\n' >>DEBIAN/conffiles; \
+ fi
install -m 755 debian/init debian/trees/daemon/etc/init.d/dnsmasq
install -m 755 debian/resolvconf debian/trees/daemon/etc/resolvconf/update.d/dnsmasq
install -m 755 debian/resolvconf-package debian/trees/daemon/usr/lib/resolvconf/dpkg-event.d/dnsmasq