summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2023-03-06 22:38:06 +0800
committerMatt Johnston <matt@ucc.asn.au>2023-03-06 22:38:06 +0800
commit4c478274b8b9bb9a12dd584be3e8b582d1f599d7 (patch)
tree3ef300658aa15e8c5909bc8ef6e10a06f11be48f
parent9ddedcc53ca1c00b94c7de1ea1edf7a5e34297b2 (diff)
downloaddropbear-4c478274b8b9bb9a12dd584be3e8b582d1f599d7.tar.gz
Fix out of tree builds
-rw-r--r--.github/workflows/build.yml2
-rw-r--r--Makefile.in8
-rw-r--r--src/default_options.h (renamed from default_options.h)0
-rwxr-xr-xsrc/ifndef_wrapper.sh (renamed from ifndef_wrapper.sh)0
4 files changed, 5 insertions, 5 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index 2ea3308..f46e87e 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -187,7 +187,7 @@ jobs:
if: ${{ matrix.nondefault }}
run: |
# Turn on anything that's off by default. Rough but seems sufficient
- grep ' 0$' default_options.h | sed 's/0$/1/' > localoptions.h
+ grep ' 0$' src/default_options.h | sed 's/0$/1/' > localoptions.h
# PAM clashes with password
echo "#define DROPBEAR_SVR_PASSWORD_AUTH 0" >> localoptions.h
# 1 second timeout is too short
diff --git a/Makefile.in b/Makefile.in
index 842a01a..026e8c9 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -12,8 +12,8 @@ ifndef PROGRAMS
PROGRAMS=dropbear dbclient dropbearkey dropbearconvert
endif
-srcdir=./src
-VPATH=$(srcdir)
+srcdir=@srcdir@/src
+VPATH=@srcdir@/src
STATIC_LTC=libtomcrypt/libtomcrypt.a
STATIC_LTM=libtommath/libtommath.a
@@ -167,10 +167,10 @@ $(OBJ_DIR):
$(OBJ_DIR)/%.o: $(srcdir)/%.c $(HEADERS) | $(OBJ_DIR)
$(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@
-default_options_guard.h: default_options.h
+default_options_guard.h: $(srcdir)/default_options.h
@echo Creating $@
@printf "/*\n > > > Do not edit this file (default_options_guard.h) < < <\nGenerated from "$^"\nLocal customisation goes in localoptions.h\n*/\n\n" > $@.tmp
- @./ifndef_wrapper.sh < $^ >> $@.tmp
+ @$(srcdir)/ifndef_wrapper.sh < $^ >> $@.tmp
@mv $@.tmp $@
@pwd
@ls -l $@
diff --git a/default_options.h b/src/default_options.h
index 5132775..5132775 100644
--- a/default_options.h
+++ b/src/default_options.h
diff --git a/ifndef_wrapper.sh b/src/ifndef_wrapper.sh
index 37a208d..37a208d 100755
--- a/ifndef_wrapper.sh
+++ b/src/ifndef_wrapper.sh