summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTJ Kolev <tjkolev@gmail.com>2023-02-04 14:26:31 -0600
committerTJ Kolev <tjkolev@gmail.com>2023-02-04 14:26:31 -0600
commit5da2360dc606816c4491f321b20e2cf5b1efa13c (patch)
tree96ab2887aaa2b8f41d53aba1ed0f39af3d439ba7
parent3045d7dba9dc55d0efead514b1be8931db6de818 (diff)
downloaddropbear-5da2360dc606816c4491f321b20e2cf5b1efa13c.tar.gz
More fixes.
* Forgot to recover the location (./) of localoptions.h. So whatever the test pipeline emits in that file goes unnoticed. * make fuzzstandalone works on my machine. tjk :)
-rw-r--r--Makefile.in8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.in b/Makefile.in
index 87d1e53..632c9c4 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -28,9 +28,9 @@ ifeq (@BUNDLED_LIBTOM@, 1)
endif
OPTION_HEADERS = default_options_guard.h $(srcdir)/sysoptions.h
-ifneq ($(wildcard $(srcdir)/localoptions.h),)
+ifneq ($(wildcard ./localoptions.h),)
CPPFLAGS+=-DLOCALOPTIONS_H_EXISTS
- OPTION_HEADERS += $(srcdir)/localoptions.h
+ OPTION_HEADERS += ./localoptions.h
endif
OBJ_DIR=./obj
@@ -76,8 +76,8 @@ SCPOBJS = $(patsubst %,$(OBJ_DIR)/%,$(_SCPOBJS))
ifeq (@DROPBEAR_FUZZ@, 1)
allobjs = $(COMMONOBJS) fuzz/fuzz-common.o fuzz/fuzz-wrapfd.o $(CLISVROBJS) $(CLIOBJS) $(SVROBJS) @CRYPTLIB@
- allobjs:=$(subst svr-main.o, ,$(allobjs))
- allobjs:=$(subst cli-main.o, ,$(allobjs))
+ allobjs:=$(subst $(OBJ_DIR)/svr-main.o, ,$(allobjs))
+ allobjs:=$(subst $(OBJ_DIR)/cli-main.o, ,$(allobjs))
dropbearobjs=$(allobjs) svr-main.o
dbclientobjs=$(allobjs) cli-main.o