summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2023-04-19 22:24:52 +0800
committerMatt Johnston <matt@ucc.asn.au>2023-04-19 22:24:52 +0800
commit6bc125e6c3c99307c2fb52e59e4f7f4562ac84a1 (patch)
treec5870b81b11119c5bcf7c7d28fd2f77a4167fd9b
parent16d855337b475d2da90cc2668e85f7464045bbcc (diff)
downloaddropbear-6bc125e6c3c99307c2fb52e59e4f7f4562ac84a1.tar.gz
Fix out-of-tree builds
Broke in the src directory move
-rw-r--r--Makefile.in5
-rw-r--r--libtomcrypt/Makefile.in2
-rw-r--r--libtommath/Makefile.in2
3 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.in b/Makefile.in
index 026e8c9..7800407 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -23,7 +23,7 @@ LIBTOM_LIBS=@LIBTOM_LIBS@
ifeq (@BUNDLED_LIBTOM@, 1)
LIBTOM_DEPS=$(STATIC_LTC) $(STATIC_LTM)
LIBTOM_CLEAN=ltc-clean ltm-clean
- CPPFLAGS+=-I./libtomcrypt/src/headers/ -I./libtommath
+ CPPFLAGS+=-I$(srcdir)/../libtomcrypt/src/headers/
LIBTOM_LIBS=$(STATIC_LTC) $(STATIC_LTM)
endif
@@ -167,6 +167,9 @@ $(OBJ_DIR):
$(OBJ_DIR)/%.o: $(srcdir)/%.c $(HEADERS) | $(OBJ_DIR)
$(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@
+fuzz/%.o: $(srcdir)/../fuzz/%.c $(HEADERS)
+ $(CC) -c $(CFLAGS) $(CPPFLAGS) $< -o $@
+
default_options_guard.h: $(srcdir)/default_options.h
@echo Creating $@
@printf "/*\n > > > Do not edit this file (default_options_guard.h) < < <\nGenerated from "$^"\nLocal customisation goes in localoptions.h\n*/\n\n" > $@.tmp
diff --git a/libtomcrypt/Makefile.in b/libtomcrypt/Makefile.in
index 15777d2..ec135c5 100644
--- a/libtomcrypt/Makefile.in
+++ b/libtomcrypt/Makefile.in
@@ -42,7 +42,7 @@ ARFLAGS = r
EXTRALIBS = ../libtommath/libtommath.a
#Compilation flags
-LTC_CFLAGS = -Isrc/headers/ -I$(srcdir)/src/headers/ -I$(srcdir)/.. -I$(srcdir)/../src -DLTC_SOURCE -I../libtommath/ -I$(srcdir)/../libtommath/ $(CFLAGS) $(CPPFLAGS)
+LTC_CFLAGS = -Isrc/headers/ -I$(srcdir)/src/headers/ -I../ -I$(srcdir)/../src -DLTC_SOURCE -I../libtommath/ -I$(srcdir)/../libtommath/ $(CFLAGS) $(CPPFLAGS)
LTC_LDFLAGS = $(LDFLAGS) $(EXTRALIBS)
VERSION=1.18.1
diff --git a/libtommath/Makefile.in b/libtommath/Makefile.in
index d44fc38..3cacdd8 100644
--- a/libtommath/Makefile.in
+++ b/libtommath/Makefile.in
@@ -6,7 +6,7 @@ VPATH=@srcdir@
srcdir=@srcdir@
# So that libtommath can include Dropbear headers for options and m_burn()
-CFLAGS += -I$(srcdir) -I../libtomcrypt/src/headers/ -I$(srcdir)/../libtomcrypt/src/headers/ -I$(srcdir)/.. -I$(srcdir)/../src
+CFLAGS += -I$(srcdir) -I../libtomcrypt/src/headers/ -I$(srcdir)/../libtomcrypt/src/headers/ -I../ -I$(srcdir)/../src
CFLAGS += -Wno-deprecated
CFLAGS += $(CPPFLAGS)