summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTJ Kolev <tjkolev@gmail.com>2023-02-03 12:11:24 -0600
committerTJ Kolev <tjkolev@gmail.com>2023-02-03 12:11:24 -0600
commitf33d4d1a914f239dced52b48e2709e23191271a2 (patch)
tree9901a49c12d663fa386745cac6333a6df602a964
parent82c3ffe7019e1db4727d7e292bf9ab88b56de278 (diff)
downloaddropbear-f33d4d1a914f239dced52b48e2709e23191271a2.tar.gz
Fixing manpages install.
Yet another fix to my file reorg. And while at it move the manuals under ther own folder - /manpages. Added a note about installing into a temporary folder to testing purposes. tjk :)
-rw-r--r--INSTALL.md5
-rw-r--r--Makefile.in9
-rw-r--r--manpages/dbclient.1 (renamed from dbclient.1)0
-rw-r--r--manpages/dropbear.8 (renamed from dropbear.8)0
-rw-r--r--manpages/dropbearconvert.1 (renamed from dropbearconvert.1)0
-rw-r--r--manpages/dropbearkey.1 (renamed from dropbearkey.1)0
6 files changed, 10 insertions, 4 deletions
diff --git a/INSTALL.md b/INSTALL.md
index e339608..9dd65f9 100644
--- a/INSTALL.md
+++ b/INSTALL.md
@@ -31,6 +31,11 @@ or
make PROGRAMS="dropbear dbclient dropbearkey dropbearconvert scp" install
```
+To test the installation targeting a temporary forder set `DESTDIR`:
+```
+make install DESTDIR=/same/temp/location
+```
+
You can leave items out of the `PROGRAMS` list to avoid compiling them. If you recompile after changing the `PROGRAMS` list, you **MUST** `make clean` before recompiling - bad things will happen otherwise.
[DEVELOPING.md](DEVELOPING.md) has some notes on other developer topics, including debugging.
diff --git a/Makefile.in b/Makefile.in
index 4a9dada..87d1e53 100644
--- a/Makefile.in
+++ b/Makefile.in
@@ -34,6 +34,7 @@ ifneq ($(wildcard $(srcdir)/localoptions.h),)
endif
OBJ_DIR=./obj
+MAN_DIR=./manpages
_COMMONOBJS=dbutil.o buffer.o dbhelpers.o \
dss.o bignum.o \
@@ -182,27 +183,27 @@ insmultidropbear: dropbearmulti$(EXEEXT)
-rm -f $(DESTDIR)$(sbindir)/dropbear$(EXEEXT)
-ln -s $(bindir)/dropbearmulti$(EXEEXT) $(DESTDIR)$(sbindir)/dropbear$(EXEEXT)
$(INSTALL) -d $(DESTDIR)$(mandir)/man8
- $(INSTALL) -m 644 $(srcdir)/dropbear.8 $(DESTDIR)$(mandir)/man8/dropbear.8
+ $(INSTALL) -m 644 $(MAN_DIR)/dropbear.8 $(DESTDIR)$(mandir)/man8/dropbear.8
insmulti%: dropbearmulti$(EXEEXT)
$(INSTALL) -d $(DESTDIR)$(bindir)
-rm -f $(DESTDIR)$(bindir)/$*$(EXEEXT)
-ln -s $(bindir)/dropbearmulti$(EXEEXT) $(DESTDIR)$(bindir)/$*$(EXEEXT)
$(INSTALL) -d $(DESTDIR)$(mandir)/man1
- if test -e $(srcdir)/$*.1; then $(INSTALL) -m 644 $(srcdir)/$*.1 $(DESTDIR)$(mandir)/man1/$*.1; fi
+ if test -e $(MAN_DIR)/$*.1; then $(INSTALL) -m 644 $(MAN_DIR)/$*.1 $(DESTDIR)$(mandir)/man1/$*.1; fi
# dropbear should go in sbin, so it needs a separate rule
inst_dropbear: dropbear
$(INSTALL) -d $(DESTDIR)$(sbindir)
$(INSTALL) dropbear$(EXEEXT) $(DESTDIR)$(sbindir)
$(INSTALL) -d $(DESTDIR)$(mandir)/man8
- $(INSTALL) -m 644 $(srcdir)/dropbear.8 $(DESTDIR)$(mandir)/man8/dropbear.8
+ $(INSTALL) -m 644 $(MAN_DIR)/dropbear.8 $(DESTDIR)$(mandir)/man8/dropbear.8
inst_%: %
$(INSTALL) -d $(DESTDIR)$(bindir)
$(INSTALL) $*$(EXEEXT) $(DESTDIR)$(bindir)
$(INSTALL) -d $(DESTDIR)$(mandir)/man1
- if test -e $(srcdir)/$*.1; then $(INSTALL) -m 644 $(srcdir)/$*.1 $(DESTDIR)$(mandir)/man1/$*.1; fi
+ if test -e $(MAN_DIR)/$*.1; then $(INSTALL) -m 644 $(MAN_DIR)/$*.1 $(DESTDIR)$(mandir)/man1/$*.1; fi
inst_dropbearmulti: $(addprefix insmulti, $(PROGRAMS))
diff --git a/dbclient.1 b/manpages/dbclient.1
index 8a916dc..8a916dc 100644
--- a/dbclient.1
+++ b/manpages/dbclient.1
diff --git a/dropbear.8 b/manpages/dropbear.8
index d9bbfc2..d9bbfc2 100644
--- a/dropbear.8
+++ b/manpages/dropbear.8
diff --git a/dropbearconvert.1 b/manpages/dropbearconvert.1
index 42f6c1b..42f6c1b 100644
--- a/dropbearconvert.1
+++ b/manpages/dropbearconvert.1
diff --git a/dropbearkey.1 b/manpages/dropbearkey.1
index d6860ea..d6860ea 100644
--- a/dropbearkey.1
+++ b/manpages/dropbearkey.1