summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2018-01-25 21:58:00 +0800
committerGitHub <noreply@github.com>2018-01-25 21:58:00 +0800
commit3d61b6eab69a9a2453e4fb807159f28c9490312a (patch)
treed95edcd96ff34d7a9d76e73b67f904ea10c5ceb9 /configure.ac
parente64e25e4d69ddb8f1c7fb8bbdcd09817cae4ca55 (diff)
parent22037d5fba702d76b5df962bb3c08d1b20b9f27d (diff)
downloaddropbear-3d61b6eab69a9a2453e4fb807159f28c9490312a.tar.gz
Merge pull request #48 from DengkeDu/dengke/configure-add-variable-to-allow-openpty-check-cached
configure: add a variable to allow openpty check to be cached
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 8 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index a3b61b3..2559b11 100644
--- a/configure.ac
+++ b/configure.ac
@@ -269,15 +269,20 @@ AC_ARG_ENABLE(openpty,
AC_MSG_NOTICE(Not using openpty)
else
AC_MSG_NOTICE(Using openpty if available)
- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY,1,[Have openpty() function])])
+ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
fi
],
[
AC_MSG_NOTICE(Using openpty if available)
- AC_SEARCH_LIBS(openpty, util, [AC_DEFINE(HAVE_OPENPTY)])
+ AC_SEARCH_LIBS(openpty, util, [dropbear_cv_func_have_openpty=yes])
]
)
-
+
+if test "x$dropbear_cv_func_have_openpty" = "xyes"; then
+ AC_DEFINE(HAVE_OPENPTY,,Have openpty() function)
+ no_ptc_check=yes
+ no_ptmx_check=yes
+fi
AC_ARG_ENABLE(syslog,
[ --disable-syslog Don't include syslog support],