summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorMatt Johnston <matt@ucc.asn.au>2013-10-04 22:22:35 +0800
committerMatt Johnston <matt@ucc.asn.au>2013-10-04 22:22:35 +0800
commit9cdd5e99a46e59d528d16f95cd8bbdcbf21665ae (patch)
treed4bb1e57b199b7b6a3d10544d2eafc1b3781c9f8 /debian/rules
parent897ed7125bd1b2618c762cb437da63f2c7b7aa8b (diff)
downloaddropbear-9cdd5e99a46e59d528d16f95cd8bbdcbf21665ae.tar.gz
Fix up debian buildDROPBEAR_2013.59
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules11
1 files changed, 4 insertions, 7 deletions
diff --git a/debian/rules b/debian/rules
index e1a4b7a..c6b2e85 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,5 +1,9 @@
#!/usr/bin/make -f
+export DEB_BUILD_MAINT_OPTIONS = hardening=+all
+DPKG_EXPORT_BUILDFLAGS = 1
+include /usr/share/dpkg/buildflags.mk
+
#export DH_OPTIONS
DEB_HOST_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?=$(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
@@ -9,13 +13,6 @@ ifneq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
STRIP =: nostrip
endif
-CFLAGS =-Wall -g
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
- CFLAGS +=-O0
-else
- CFLAGS +=-O2
-endif
-
CONFFLAGS =
CC =gcc
ifneq (,$(findstring diet,$(DEB_BUILD_OPTIONS)))