summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-05-05 17:21:22 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-05-26 11:20:57 +0200
commit9c8f9bea8e3356788c2208fa2a9be6c419480ddf (patch)
tree6f8221193af137dd875b96c761963faffb6520f2
parentdfc0ed16992e4610a2128ae8a14b7b51c4ceeab5 (diff)
downloadfirewall3-9c8f9bea8e3356788c2208fa2a9be6c419480ddf.tar.gz
Link libext dynamically
Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
-rw-r--r--CMakeLists.txt19
1 files changed, 3 insertions, 16 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a57cb7b..bfaa3eb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -14,24 +14,11 @@ EXECUTE_PROCESS(COMMAND sed -n -e "s/${sed_match}/${sed_replace}/; T n; H; :n; \
SET(CMAKE_SHARED_LIBRARY_LINK_C_FLAGS "")
SET(CMAKE_EXE_LINKER_FLAGS "${CMAKE_EXE_LINKER_FLAGS} -Wl,--unresolved-symbols=ignore-all ${ext_syms}")
-IF (EXISTS "${CMAKE_SOURCE_DIR}/libext.a")
- ADD_LIBRARY(ext STATIC IMPORTED)
- SET_PROPERTY(TARGET ext PROPERTY IMPORTED_LOCATION ${CMAKE_SOURCE_DIR}/libext.a)
- LIST(APPEND ext_libs ext)
-ENDIF()
-
-IF (EXISTS "${CMAKE_SOURCE_DIR}/libext4.a")
- ADD_LIBRARY(ext4 STATIC IMPORTED)
- SET_PROPERTY(TARGET ext4 PROPERTY IMPORTED_LOCATION "${CMAKE_SOURCE_DIR}/libext4.a")
- LIST(APPEND ext_libs ext4)
-ENDIF()
+LIST(APPEND ext_libs iptext)
+LIST(APPEND ext_libs iptext4)
IF (NOT DISABLE_IPV6)
- IF (EXISTS "${CMAKE_SOURCE_DIR}/libext6.a")
- ADD_LIBRARY(ext6 STATIC IMPORTED)
- SET_PROPERTY(TARGET ext6 PROPERTY IMPORTED_LOCATION "${CMAKE_SOURCE_DIR}/libext6.a")
- LIST(APPEND ext_libs ext6)
- ENDIF()
+ LIST(APPEND ext_libs iptext6)
LIST(APPEND iptc_libs ip6tc)
ELSE()
ADD_DEFINITIONS(-DDISABLE_IPV6)